summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-07 15:03:39 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-07 15:03:39 +0200
commit932df82d42acc1018e68f3d0034d91cc0de20b13 (patch)
tree3beca6856560c533cb3a135d48cc4817407dcdd8
php-league-plates: 3.1.1
-rw-r--r--Makefile4
-rw-r--r--composer.json35
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-league-plates-autoload.php16
-rw-r--r--php-league-plates.spec121
5 files changed, 204 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f8bc719
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "league/plates",
+ "description": "Plates, the native PHP template system that's fast, easy to use and easy to extend.",
+ "keywords": [
+ "league",
+ "package",
+ "templating",
+ "templates",
+ "views"
+ ],
+ "homepage": "http://platesphp.com",
+ "license": "MIT",
+ "authors" : [
+ {
+ "name": "Jonathan Reinink",
+ "email": "jonathan@reinink.ca",
+ "role": "Developer"
+ }
+ ],
+ "require-dev": {
+ "phpunit/phpunit": "~4.0",
+ "mikey179/vfsStream": "~1.4.0",
+ "squizlabs/php_codesniffer": "~1.5"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Plates\\": "src"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.0-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..e9a1ec5
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-league-plates-autoload.php b/php-league-plates-autoload.php
new file mode 100644
index 0000000..e85c14f
--- /dev/null
+++ b/php-league-plates-autoload.php
@@ -0,0 +1,16 @@
+<?php
+/* Autoloader for league/plates and its dependencies */
+
+$vendorDir = '/usr/share/php';
+// Use Symfony autoloader
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('League\\Plates\\', dirname(dirname(__DIR__)));
+
diff --git a/php-league-plates.spec b/php-league-plates.spec
new file mode 100644
index 0000000..9babb91
--- /dev/null
+++ b/php-league-plates.spec
@@ -0,0 +1,121 @@
+# remirepo/fedora spec file for php-league-plates
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+# Github
+%global gh_commit 2d8569e9f140a70d6a05db38006926f7547cb802
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner thephpleague
+%global gh_project plates
+# Packagist
+%global pk_vendor league
+%global pk_name plates
+# PSR-0 namespace
+%global ns_vendor League
+%global ns_project Plates
+
+Name: php-%{pk_vendor}-%{pk_name}
+Version: 3.1.1
+Release: 1%{?dist}
+Summary: Native PHP template system
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Create git snapshot as tests are excluded from official tarball
+Source1: makesrc.sh
+# Autoloader
+Source2: %{name}-autoload.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "~4.0",
+# "mikey179/vfsStream": "~1.4.0",
+# "squizlabs/php_codesniffer": "~1.5"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(mikey179/vfsStream) >= 0.9
+# Autoloader
+BuildRequires: php-composer(symfony/class-loader)
+
+# From phpcompatifo report for 3.1.1
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(symfony/class-loader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
+
+
+%description
+Plates is a native PHP template system that's fast, easy to use and easy
+to extend. It's inspired by the excellent Twig template engine and strives
+to bring modern template language functionality to native PHP templates.
+Plates is designed for developers who prefer to use native PHP templates
+over compiled template languages, such as Twig or Smarty.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+install -pm 644 %{SOURCE2} src/autoload.php
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+
+# Restore PSR-0 tree
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+: Generate a simple autoloader
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+// Installed library
+require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
+
+// Dependency
+require_once '%{_datadir}/php/org/bovigo/vfs/autoload.php';
+EOF
+
+: Run upstream test suite
+%{_bindir}/phpunit --verbose
+
+if which php70
+then php70 %{_bindir}/phpunit --verbose
+fi
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/%{ns_vendor}
+
+
+%changelog
+* Thu Apr 7 2016 Remi Collet <remi@fedoraproject.org> - 3.1.1-1
+- initial package, version 3.1.1
+