summaryrefslogtreecommitdiffstats
path: root/php-league-mime-type-detection.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-22 08:07:14 +0200
committerRemi Collet <remi@remirepo.net>2020-09-22 08:07:14 +0200
commit37e7b6f8c8c6932d0fb809d4f91153b81b24c699 (patch)
tree7470c869dd865e5b3b2c21b0b10138a624993049 /php-league-mime-type-detection.spec
parent29d48958a8bbb33fe1fa334abadbcdb57346ad44 (diff)
update to 1.5.0
add patch for test suite from upstream and from https://github.com/thephpleague/mime-type-detection/pull/3 open https://github.com/thephpleague/mime-type-detection/pull/4 phpunit 9 switch to phpunit9
Diffstat (limited to 'php-league-mime-type-detection.spec')
-rw-r--r--php-league-mime-type-detection.spec35
1 files changed, 27 insertions, 8 deletions
diff --git a/php-league-mime-type-detection.spec b/php-league-mime-type-detection.spec
index 3ceb78e..6783bf6 100644
--- a/php-league-mime-type-detection.spec
+++ b/php-league-mime-type-detection.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit fda190b62b962d96a069fcc414d781db66d65b69
+%global gh_commit ea2fbfc988bade315acd5967e6d02274086d0f28
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project mime-type-detection
@@ -19,7 +19,7 @@
%global ns_project MimeTypeDetection
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.4.0
+Version: 1.5.0
Release: 1%{?dist}
Summary: Mime-type detection for Flysystem
@@ -29,6 +29,9 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# Create git snapshot as tests are excluded from official tarball
Source1: makesrc.sh
+Patch0: https://github.com/thephpleague/mime-type-detection/commit/485f75211335bfd69882bee7d3fccc730485aa82.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/thephpleague/mime-type-detection/pull/3.patch
+
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -37,7 +40,13 @@ BuildRequires: php-json
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^8.5.8",
# "phpstan/phpstan": "^0.12.36"
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+BuildRequires: phpunit9 >= 9.3
+%global phpunit %{_bindir}/phpunit9
+%else
BuildRequires: phpunit8 >= 8.5.8
+%global phpunit %{_bindir}/phpunit8
+%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -63,6 +72,8 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+%patch1 -p1
%build
@@ -91,12 +102,13 @@ EOF
: Run upstream test suite
# the_generated_map_should_be_up_to_date is online
ret=0
-for cmd in php php72 php73 php74 php80; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit8 \
- --filter '^((?!(the_generated_map_should_be_up_to_date)).)*$' \
- --no-coverage \
- --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} \
+ --filter '^((?!(the_generated_map_should_be_up_to_date)).)*$' \
+ --no-coverage \
+ --verbose || ret=1
fi
done
exit $ret
@@ -113,5 +125,12 @@ exit $ret
%changelog
+* Tue Sep 22 2020 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+- add patch for test suite from upstream and from
+ https://github.com/thephpleague/mime-type-detection/pull/3
+- open https://github.com/thephpleague/mime-type-detection/pull/4 phpunit 9
+- switch to phpunit9
+
* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
- initial package