summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-24 08:06:36 +0200
committerRemi Collet <remi@remirepo.net>2020-08-24 08:06:36 +0200
commit29d48958a8bbb33fe1fa334abadbcdb57346ad44 (patch)
treee06b476f0ab752a7496af87cf074b71380e992f1
initial package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json24
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-league-mime-type-detection.spec117
5 files changed, 182 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..19a62a7
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,24 @@
+{
+ "name": "league/mime-type-detection",
+ "description": "Mime-type detection for Flysystem",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Frank de Jonge",
+ "email": "info@frankdejonge.nl"
+ }
+ ],
+ "require": {
+ "php": "^7.2 || ^8.0",
+ "ext-fileinfo": "*"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^8.5.8",
+ "phpstan/phpstan": "^0.12.36"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\MimeTypeDetection\\": "src"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..37cb6a2
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-league-mime-type-detection.spec b/php-league-mime-type-detection.spec
new file mode 100644
index 0000000..3ceb78e
--- /dev/null
+++ b/php-league-mime-type-detection.spec
@@ -0,0 +1,117 @@
+# remirepo/fedora spec file for php-league-mime-type-detection
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+# Github
+%global gh_commit fda190b62b962d96a069fcc414d781db66d65b69
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner thephpleague
+%global gh_project mime-type-detection
+# Packagist
+%global pk_vendor league
+%global pk_name mime-type-detection
+# Namespace
+%global ns_vendor League
+%global ns_project MimeTypeDetection
+
+Name: php-%{pk_vendor}-%{pk_name}
+Version: 1.4.0
+Release: 1%{?dist}
+Summary: Mime-type detection for Flysystem
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+# Create git snapshot as tests are excluded from official tarball
+Source1: makesrc.sh
+
+BuildArch: noarch
+
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-fileinfo
+BuildRequires: php-json
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "^8.5.8",
+# "phpstan/phpstan": "^0.12.36"
+BuildRequires: phpunit8 >= 8.5.8
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer.json, "require": {
+# "php": "^7.2 || ^8.0",
+# "ext-fileinfo": "*"
+Requires: php(language) >= 7.2
+Requires: php-fileinfo
+# From phpcompatifo report for 1.4.0
+Requires: php-json
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
+
+
+%description
+This package supplies a generic mime-type detection interface with a finfo
+based implementation.
+
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Create classmap autoloader
+phpab \
+ --template fedora \
+ --output src/autoload.php \
+ src
+
+
+%install
+# Restore PSR-0 tree
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
+
+
+%check
+: Generate a simple autoloader
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+// Installed library
+require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
+EOF
+
+: Run upstream test suite
+# the_generated_map_should_be_up_to_date is online
+ret=0
+for cmd in php php72 php73 php74 php80; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 \
+ --filter '^((?!(the_generated_map_should_be_up_to_date)).)*$' \
+ --no-coverage \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/%{ns_vendor}
+%exclude %{_datadir}/php/%{ns_vendor}/%{ns_project}/*Test.php
+
+
+%changelog
+* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- initial package