summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-24 17:17:26 +0200
committerRemi Collet <remi@remirepo.net>2017-04-24 17:17:26 +0200
commitf3f7b9db2979c5b8972c59efdbc9f835f27cc9a2 (patch)
tree3799e6f5740366e71bf662d700fba3f9758815c9
parentef02e0845e885286f306a6b54deb53823caa9813 (diff)
v1.0.38
-rw-r--r--composer.json2
-rw-r--r--php-league-flysystem.spec40
2 files changed, 12 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index 0ef4535..8f8758c 100644
--- a/composer.json
+++ b/composer.json
@@ -41,7 +41,7 @@
"league/flysystem-webdav": "Allows you to use WebDAV storage",
"league/flysystem-aws-s3-v2": "Allows you to use S3 storage with AWS SDK v2",
"league/flysystem-aws-s3-v3": "Allows you to use S3 storage with AWS SDK v3",
- "league/flysystem-dropbox": "Allows you to use Dropbox storage",
+ "spatie/flysystem-dropbox": "Allows you to use Dropbox storage",
"league/flysystem-cached-adapter": "Flysystem adapter decorator for metadata caching",
"league/flysystem-sftp": "Allows you to use SFTP server storage via phpseclib",
"league/flysystem-ziparchive": "Allows you to use ZipArchive adapter"
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index 8e684f7..222249a 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 78b5cc4feb61a882302df4fbaf63b7662e5e4ccd
+%global gh_commit 4ba6e13f5116204b21c3afdf400ecf2b9eb1c482
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project flysystem
@@ -19,7 +19,7 @@
%global ns_project Flysystem
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.0.37
+Version: 1.0.38
Release: 1%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
@@ -30,7 +30,6 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# Create git snapshot as tests are excluded from official tarball
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.5.9
BuildRequires: php-date
@@ -89,8 +88,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
# Restore PSR-0 tree
mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}
@@ -121,36 +118,18 @@ then PHPSPEC=/dev/null
else PHPSPEC=%{_bindir}/phpspec
fi
-# remirepo:15
-run=0
ret=0
-if which php56; then
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
: Run upstream test suite with PHP 5
- php56 $PHPSPEC run || ret=1
- php56 %{_bindir}/phpunit --verbose || ret=1
- run=1
-fi
-if which php71; then
- : Run upstream test suite with PHP 7
- php71 $PHPSPEC run || ret=1
- php71 %{_bindir}/phpunit --verbose || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-: Run upstream test suite
-%{_bindir}/php $PHPSPEC run
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+ $cmd $PHPSPEC run || ret=1
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -159,6 +138,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Apr 24 2017 Remi Collet <remi@remirepo.net> - 1.0.38-1
+- Update to 1.0.38
+
* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 1.0.37-1
- Update to 1.0.37