summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-11 12:05:24 +0200
committerRemi Collet <remi@remirepo.net>2019-10-11 12:05:24 +0200
commite6e4d78f92d2b260eb5eb416588e9a48b82fbd95 (patch)
tree4dd45cc5f86579991f48827f548adcbc1a273067
parent332d42e42216b223fa877446fdbf2cc91dfe534f (diff)
- add patch for PHP 7.4 from
https://github.com/thephpleague/flysystem/pull/1081
-rw-r--r--1081.patch22
-rw-r--r--php-league-flysystem.spec12
2 files changed, 31 insertions, 3 deletions
diff --git a/1081.patch b/1081.patch
new file mode 100644
index 0000000..71c0dd4
--- /dev/null
+++ b/1081.patch
@@ -0,0 +1,22 @@
+From 1c4f297d30f51493c6ed54c827ad85132b3c8f61 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 11 Oct 2019 12:00:18 +0200
+Subject: [PATCH] add 'application/x-empty' for 7.4
+
+---
+ src/Adapter/Local.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Adapter/Local.php b/src/Adapter/Local.php
+index 3236349a..c6e6fa86 100644
+--- a/src/Adapter/Local.php
++++ b/src/Adapter/Local.php
+@@ -319,7 +319,7 @@ public function getMimetype($path)
+ $finfo = new Finfo(FILEINFO_MIME_TYPE);
+ $mimetype = $finfo->file($location);
+
+- if (in_array($mimetype, ['application/octet-stream', 'inode/x-empty'])) {
++ if (in_array($mimetype, ['application/octet-stream', 'inode/x-empty', 'application/x-empty'])) {
+ $mimetype = Util\MimeType::detectByFilename($location);
+ }
+
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index 777bdf2..4f13b54 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -20,7 +20,7 @@
Name: php-%{pk_vendor}-%{pk_name}
Version: 1.0.55
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
License: MIT
@@ -29,6 +29,8 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# Create git snapshot as tests are excluded from official tarball
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/thephpleague/flysystem/pull/1081.patch
+
BuildArch: noarch
# As we use phpunit 6 and phpspec 5
BuildRequires: php(language) >= 7.1
@@ -74,6 +76,7 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
%build
@@ -117,8 +120,7 @@ else PHPSPEC=%{_bindir}/phpspec
fi
ret=0
-# TODO 7.4: 1 failed test (testMimetypeFallbackOnExtension)
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
: Run upstream test suite
$cmd $PHPSPEC run || ret=1
@@ -140,6 +142,10 @@ exit $ret
%changelog
+* Fri Oct 11 2019 Remi Collet <remi@remirepo.net> - 1.0.55-2
+- add patch for PHP 7.4 from
+ https://github.com/thephpleague/flysystem/pull/1081
+
* Mon Aug 26 2019 Remi Collet <remi@remirepo.net> - 1.0.55-1
- update to 1.0.55