summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-22 14:49:07 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-22 14:49:07 +0200
commitc5462171a4aff10305ded467992e02827ad58155 (patch)
treefb51e5272caa97dafc23870556d9aa041ae5a44f
parent7de5af5e3072be192da93baf1ed0a261d88b6e70 (diff)
php-league-flysystem: 1.0.21
-rw-r--r--composer.json60
-rw-r--r--php-league-flysystem.spec7
2 files changed, 65 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..96a8f98
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,60 @@
+{
+ "name": "league/flysystem",
+ "description": "Filesystem abstraction: Many filesystems, one API.",
+ "keywords": [
+ "filesystem", "filesystems", "files", "storage", "dropbox", "aws",
+ "abstraction", "s3", "ftp", "sftp", "remote", "webdav",
+ "file systems", "cloud", "cloud files", "rackspace", "copy.com"
+ ],
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Frank de Jonge",
+ "email": "info@frenky.net"
+ }
+ ],
+ "require": {
+ "php": ">=5.4.0"
+ },
+ "require-dev": {
+ "ext-fileinfo": "*",
+ "phpunit/phpunit": "~4.8 || ~5.0",
+ "mockery/mockery": "~0.9",
+ "phpspec/phpspec": "^2.2"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Flysystem\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "League\\Flysystem\\Stub\\": "stub/"
+ }
+ },
+ "suggest": {
+ "ext-fileinfo": "Required for MimeType",
+ "league/flysystem-eventable-filesystem": "Allows you to use EventableFilesystem",
+ "league/flysystem-rackspace": "Allows you to use Rackspace Cloud Files",
+ "league/flysystem-copy": "Allows you to use Copy.com storage",
+ "league/flysystem-azure": "Allows you to use Windows Azure Blob storage",
+ "league/flysystem-webdav": "Allows you to use WebDAV storage",
+ "league/flysystem-aws-s3-v2": "Allows you to use S3 storage with AWS SDK v2",
+ "league/flysystem-aws-s3-v3": "Allows you to use S3 storage with AWS SDK v3",
+ "league/flysystem-dropbox": "Allows you to use Dropbox storage",
+ "league/flysystem-cached-adapter": "Flysystem adapter decorator for metadata caching",
+ "league/flysystem-sftp": "Allows you to use SFTP server storage via phpseclib",
+ "league/flysystem-ziparchive": "Allows you to use ZipArchive adapter"
+ },
+ "conflict": {
+ "league/flysystem-sftp": "<1.0.6"
+ },
+ "config": {
+ "bin-dir": "bin"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1-dev"
+ }
+ }
+}
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index a0e17c9..c9fd548 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit e87a786e3ae12a25cf78a71bb07b4b384bfaa83a
+%global gh_commit 35a83cf67d80d7040f306c77b0a84b9fbcc4fbfb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project flysystem
@@ -19,7 +19,7 @@
%global ns_project Flysystem
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.0.20
+Version: 1.0.21
Release: 1%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
@@ -138,6 +138,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 1.0.21-1
+- update to 1.0.21
+
* Tue Mar 15 2016 Remi Collet <remi@fedoraproject.org> - 1.0.20-1
- update to 1.0.20