summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-18 19:05:12 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-18 19:05:12 +0200
commit98024f0a4d6ecfe9152a0a98a3ed708cf66ff519 (patch)
tree5257c4db22e6e2d47ad22267518d8609a4bb1607
parent3ec7c45e08485aead47552fdcb612510c5a716ef (diff)
php-league-flysystem: 1.0.25
-rw-r--r--composer.json2
-rw-r--r--php-league-flysystem.spec40
2 files changed, 33 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 96a8f98..62bce3c 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
},
"require-dev": {
"ext-fileinfo": "*",
- "phpunit/phpunit": "~4.8 || ~5.0",
+ "phpunit/phpunit": "~4.8",
"mockery/mockery": "~0.9",
"phpspec/phpspec": "^2.2"
},
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index 87cbc02..418fd70 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 9aca859a303fdca30370f42b8c611d9cf0dedf4b
+%global gh_commit a76afa4035931be0c78ca8efc6abf3902362f437
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project flysystem
@@ -19,7 +19,7 @@
%global ns_project Flysystem
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.0.24
+Version: 1.0.25
Release: 1%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
@@ -114,15 +114,35 @@ EOF
sed -e 's/file="[^"]*"//' -i phpunit.xml
echo 'bootstrap: vendor/autoload.php' >>phpspec.yml
+PHPSPECVER=$(%{_bindir}/phpspec --version | sed 's/.* //;s/\..*//')
+if [ "$PHPSPECVER" -ge 3 ]
+then PHPSPEC=/dev/null
+else PHPSPEC=%{_bindir}/phpspec
+fi
+
+# remirepo:15
+run=0
+ret=0
+if which php56; then
+ : Run upstream test suite with PHP 5
+ php56 $PHPSPEC run || ret=1
+ php56 %{_bindir}/phpunit --verbose || ret=1
+ run=1
+fi
+if which php71; then
+ : Run upstream test suite with PHP 7
+ php71 $PHPSPEC run || ret=1
+ php71 %{_bindir}/phpunit --verbose || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
: Run upstream test suite
-%{_bindir}/phpspec run
+%{_bindir}/php $PHPSPEC run
%{_bindir}/phpunit --verbose
-
-if which php70; then
- : Run upstream test suite with PHP 7
- php70 %{_bindir}/phpspec run
- php70 %{_bindir}/phpunit --verbose
+# remirepo:2
fi
+exit $ret
+
%clean
rm -rf %{buildroot}
@@ -138,6 +158,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 18 2016 Remi Collet <remi@fedoraproject.org> - 1.0.25-1
+- update to 1.0.25
+- disable spec test suite with phpspec 3
+
* Sat Jun 4 2016 Remi Collet <remi@fedoraproject.org> - 1.0.24-1
- update to 1.0.24