summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-09-15 07:58:00 +0200
committerRemi Collet <remi@remirepo.net>2018-09-15 07:58:00 +0200
commit8d6dae8ca5792458c6ad462208b6d9d1bae23d33 (patch)
tree705265e6d2e5b534b508b2a59a8be2286a6c3620
parentb595bba780bd95e170ac394b9a2403d8ad258ba5 (diff)
v1.0.47
-rw-r--r--composer.json4
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-league-flysystem.spec11
3 files changed, 11 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 758ef9b..696c26f 100644
--- a/composer.json
+++ b/composer.json
@@ -14,10 +14,10 @@
}
],
"require": {
- "php": ">=5.5.9"
+ "php": ">=5.5.9",
+ "ext-fileinfo": "*"
},
"require-dev": {
- "ext-fileinfo": "*",
"phpspec/phpspec": "^3.4",
"phpunit/phpunit": "^5.7.10"
},
diff --git a/makesrc.sh b/makesrc.sh
index 87d223d..37cb6a2 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -20,7 +20,7 @@ cp composer.json ../composer.json
popd
echo "Archiving..."
-tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
echo "Cleaning..."
rm -rf $PROJECT-$COMMIT
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index 6dbee37..593fcfe 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit f3e0d925c18b92cf3ce84ea5cc58d62a1762a2b2
+%global gh_commit a11e4a75f256bdacf99d20780ce42d3b8272975c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project flysystem
@@ -19,7 +19,7 @@
%global ns_project Flysystem
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.0.46
+Version: 1.0.47
Release: 1%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
@@ -48,10 +48,12 @@ BuildRequires: phpunit6
BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
+# "php": ">=5.5.9",
+# "ext-fileinfo": "*"
Requires: php(language) >= 5.5.9
+Requires: php-fileinfo
# From phpcompatifo report for 1.0.29
Requires: php-date
-Requires: php-fileinfo
Requires: php-ftp
Requires: php-hash
Requires: php-mbstring
@@ -137,6 +139,9 @@ exit $ret
%changelog
+* Sat Sep 15 2018 Remi Collet <remi@remirepo.net> - 1.0.47-1
+- update to 1.0.47
+
* Wed Aug 22 2018 Remi Collet <remi@remirepo.net> - 1.0.46-1
- update to 1.0.46