summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-20 07:31:44 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-20 07:31:44 +0100
commit126359331de7f8d9e5fd133a6090a45e043eb4aa (patch)
tree07f025aec0908cfa82daf561b16a7ac10d772bf1
parent9f0c1ba2f298799c28d0a54560d213531aa1f31b (diff)
php-league-flysystem: 1.0.17
-rw-r--r--php-league-flysystem-pr592.patch125
-rw-r--r--php-league-flysystem.spec16
2 files changed, 7 insertions, 134 deletions
diff --git a/php-league-flysystem-pr592.patch b/php-league-flysystem-pr592.patch
deleted file mode 100644
index fde5df7..0000000
--- a/php-league-flysystem-pr592.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-From a7e1a712ad94962692785a12a8656c9eb9b3004a Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 14 Jan 2016 08:51:41 +0100
-Subject: [PATCH] drop dep on deprecated prophecy-phpunit (since PHPUnit 4.5)
- and allow PHPUnit 5
-
----
- composer.json | 5 ++---
- tests/FilesystemTests.php | 3 +--
- tests/GetWithMetadataTests.php | 3 +--
- tests/HandlerTests.php | 3 +--
- tests/ListFilesTests.php | 3 +--
- tests/ListPathsTests.php | 3 +--
- tests/ListWithTests.php | 3 +--
- 7 files changed, 8 insertions(+), 15 deletions(-)
-
-diff --git a/composer.json b/composer.json
-index 0b6721f..96a8f98 100644
---- a/composer.json
-+++ b/composer.json
-@@ -18,10 +18,9 @@
- },
- "require-dev": {
- "ext-fileinfo": "*",
-- "phpunit/phpunit": "~4.8",
-+ "phpunit/phpunit": "~4.8 || ~5.0",
- "mockery/mockery": "~0.9",
-- "phpspec/phpspec": "^2.2",
-- "phpspec/prophecy-phpunit": "~1.0"
-+ "phpspec/phpspec": "^2.2"
- },
- "autoload": {
- "psr-4": {
-diff --git a/tests/FilesystemTests.php b/tests/FilesystemTests.php
-index 133177e..bab76bc 100644
---- a/tests/FilesystemTests.php
-+++ b/tests/FilesystemTests.php
-@@ -4,10 +4,9 @@
- use League\Flysystem\Util;
- use Prophecy\Argument;
- use Prophecy\Argument\Token\TypeToken;
--use Prophecy\PhpUnit\ProphecyTestCase;
- use Prophecy\Prophecy\ObjectProphecy;
-
--class FilesystemTests extends ProphecyTestCase
-+class FilesystemTests extends \PHPUnit_Framework_TestCase
- {
- /**
- * @var ObjectProphecy
-diff --git a/tests/GetWithMetadataTests.php b/tests/GetWithMetadataTests.php
-index 4b43725..dd4e639 100644
---- a/tests/GetWithMetadataTests.php
-+++ b/tests/GetWithMetadataTests.php
-@@ -2,10 +2,9 @@
-
-
- use League\Flysystem\Plugin\GetWithMetadata;
--use Prophecy\PhpUnit\ProphecyTestCase;
- use Prophecy\Prophecy\ObjectProphecy;
-
--class GetWithMetadataTests extends ProphecyTestCase
-+class GetWithMetadataTests extends \PHPUnit_Framework_TestCase
- {
- /**
- * @var ObjectProphecy
-diff --git a/tests/HandlerTests.php b/tests/HandlerTests.php
-index d282c6b..9ec279b 100644
---- a/tests/HandlerTests.php
-+++ b/tests/HandlerTests.php
-@@ -3,9 +3,8 @@
-
- use League\Flysystem\Directory;
- use League\Flysystem\File;
--use Prophecy\PhpUnit\ProphecyTestCase;
-
--class HandlerTests extends ProphecyTestCase
-+class HandlerTests extends \PHPUnit_Framework_TestCase
- {
- public function testFileRead()
- {
-diff --git a/tests/ListFilesTests.php b/tests/ListFilesTests.php
-index c393461..7e42303 100644
---- a/tests/ListFilesTests.php
-+++ b/tests/ListFilesTests.php
-@@ -2,9 +2,8 @@
-
-
- use League\Flysystem\Plugin\ListFiles;
--use Prophecy\PhpUnit\ProphecyTestCase;
-
--class ListFilesTests extends ProphecyTestCase
-+class ListFilesTests extends \PHPUnit_Framework_TestCase
- {
- private $filesystem;
- private $actualFilesystem;
-diff --git a/tests/ListPathsTests.php b/tests/ListPathsTests.php
-index 328f1da..160d6ba 100644
---- a/tests/ListPathsTests.php
-+++ b/tests/ListPathsTests.php
-@@ -2,9 +2,8 @@
-
-
- use League\Flysystem\Plugin\ListPaths;
--use Prophecy\PhpUnit\ProphecyTestCase;
-
--class ListPathsTests extends ProphecyTestCase
-+class ListPathsTests extends \PHPUnit_Framework_TestCase
- {
- private $filesystem;
- private $actualFilesystem;
-diff --git a/tests/ListWithTests.php b/tests/ListWithTests.php
-index e9a2a26..3f5db84 100644
---- a/tests/ListWithTests.php
-+++ b/tests/ListWithTests.php
-@@ -3,9 +3,8 @@
- namespace League\Flysystem\Adapter;
-
- use League\Flysystem\Plugin\ListWith;
--use Prophecy\PhpUnit\ProphecyTestCase;
-
--class ListWithTests extends ProphecyTestCase
-+class ListWithTests extends \PHPUnit_Framework_TestCase
- {
- public function testHandle()
- {
diff --git a/php-league-flysystem.spec b/php-league-flysystem.spec
index 23d2aec..76c8e72 100644
--- a/php-league-flysystem.spec
+++ b/php-league-flysystem.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
# Github
-%global gh_commit 183e1a610664baf6dcd6fceda415baf43cbdc031
+%global gh_commit 02f5b6c9a8b9278c8381e3361e7bd9d641c740ca
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project flysystem
@@ -19,7 +19,7 @@
%global ns_project Flysystem
Name: php-%{pk_vendor}-%{pk_name}
-Version: 1.0.16
+Version: 1.0.17
Release: 1%{?dist}
Summary: Filesystem abstraction: Many filesystems, one API
@@ -32,9 +32,6 @@ Source1: makesrc.sh
# Autoloader
Source2: %{name}-autoload.php
-# https://github.com/thephpleague/flysystem/pull/592
-Patch1: %{name}-pr592.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.4
@@ -45,10 +42,9 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.8", => 5.x is ok
+# "phpunit/phpunit": "~4.8 || ~5.0",
# "mockery/mockery": "~0.9",
-# "phpspec/phpspec": "^2.2",
-# "phpspec/prophecy-phpunit": "~1.0" => unneeded see our patch
+# "phpspec/phpspec": "^2.2"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php-composer(mockery/mockery) >= 0.9
BuildRequires: php-composer(phpspec/phpspec) >= 2.2
@@ -81,7 +77,6 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch1 -p1
install -pm 644 %{SOURCE2} src/autoload.php
@@ -143,6 +138,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Feb 20 2016 Remi Collet <remi@fedoraproject.org> - 1.0.17-1
+- update to 1.0.17
+
* Thu Jan 14 2016 Remi Collet <remi@fedoraproject.org> - 1.0.16-1
- initial package
- open https://github.com/thephpleague/flysystem/pull/592 - PHPUnit \ No newline at end of file