summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-25 13:55:18 +0200
committerRemi Collet <remi@php.net>2021-10-25 13:55:18 +0200
commit8e1205d16551d10a4ef66dc069d1d33c4007cbcf (patch)
tree7b3bd560a8ed7892aa769880b31b64586e3ac41b
duplicate v3
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json62
l---------makesrc.sh1
-rwxr-xr-xphp-league-container4-get-source.sh71
-rw-r--r--php-league-container4.spec172
6 files changed, 319 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..61cedd9
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,62 @@
+{
+ "name": "league/container",
+ "description": "A fast and intuitive dependency injection container.",
+ "keywords": [
+ "league",
+ "container",
+ "dependency",
+ "injection",
+ "di",
+ "service",
+ "provider"
+ ],
+ "homepage": "https://github.com/thephpleague/container",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Phil Bennett",
+ "email": "philipobenito@gmail.com",
+ "homepage": "http://www.philipobenito.com",
+ "role": "Developer"
+ }
+ ],
+ "require": {
+ "php": "^7.0 || ^8.0",
+ "psr/container": "^1.0.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.0 || ^7.0",
+ "roave/security-advisories": "dev-latest",
+ "scrutinizer/ocular": "^1.8",
+ "squizlabs/php_codesniffer": "^3.5"
+ },
+ "provide": {
+ "psr/container-implementation": "^1.0"
+ },
+ "replace": {
+ "orno/di": "~2.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Container\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "League\\Container\\Test\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.x-dev",
+ "dev-3.x": "3.x-dev",
+ "dev-2.x": "2.x-dev",
+ "dev-1.x": "1.x-dev"
+ }
+ },
+ "scripts": {
+ "test": [
+ "phpunit"
+ ]
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..13fcb24
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-league-container4-get-source.sh \ No newline at end of file
diff --git a/php-league-container4-get-source.sh b/php-league-container4-get-source.sh
new file mode 100755
index 0000000..4ad1051
--- /dev/null
+++ b/php-league-container4-get-source.sh
@@ -0,0 +1,71 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-league-container4.spec b/php-league-container4.spec
new file mode 100644
index 0000000..6b94cd6
--- /dev/null
+++ b/php-league-container4.spec
@@ -0,0 +1,172 @@
+# remirepo spec file for php-league-container
+#
+# Fedora spec file for php-league-container
+#
+# Copyright (c) 2016-2021 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner thephpleague
+%global github_name container
+%global github_version 3.4.1
+%global github_commit 84ecbc2dbecc31bd23faf759a0e329ee49abddbd
+
+%global composer_vendor league
+%global composer_project container
+
+# "php": "^7.0"
+%global php_min_ver 7.0
+# "psr/container": "^1.0.0"
+%global psr_container_min_ver 1.0
+%global psr_container_max_ver 2
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: A fast and intuitive dependency injection container
+
+License: MIT
+URL: http://container.thephpleague.com/
+
+# GitHub export does not include tests.
+# Run php-league-container-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: phpunit8
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/container) >= %{psr_container_min_ver} with php-composer(psr/container) < %{psr_container_max_ver})
+%else
+BuildRequires: php-composer(psr/container) >= %{psr_container_min_ver}
+BuildRequires: php-composer(psr/container) < %{psr_container_max_ver}
+%endif
+## phpcompatinfo (computed from version 3.2.2)
+BuildRequires: php-reflection
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/container) >= %{psr_container_min_ver} with php-composer(psr/container) < %{psr_container_max_ver})
+%else
+Requires: php-composer(psr/container) >= %{psr_container_min_ver}
+Requires: php-composer(psr/container) < %{psr_container_max_ver}
+%endif
+# phpcompatinfo (computed from version 3.3.5)
+Requires: php-reflection
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+Provides: php-composer(psr/container-implementation) = 1.0
+
+%description
+A small but powerful dependency injection container that allows you to decouple
+components in your application in order to write clean and testable code.
+
+Autoloader: %{phpdir}/League/Container/autoload.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('League\\Container\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Psr/Container/autoload.php',
+]);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/League
+cp -rp src %{buildroot}%{phpdir}/League/Container
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+require '%{buildroot}%{phpdir}/League/Container/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('League\\Container\\Test\\', __DIR__.'/tests');
+BOOTSTRAP
+
+: cleanup for phpunit8/9
+sed -e '/log/d' -i phpunit.xml
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit8)
+for PHP_EXEC in php php73 php74 php80; do
+ if [ "php" = "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC $PHPUNIT --bootstrap bootstrap.php --verbose || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CHANGELOG.md
+%doc composer.json
+%doc CONTRIBUTING.md
+%doc README.md
+%dir %{phpdir}/League
+ %{phpdir}/League/Container
+
+
+%changelog
+* Fri Jul 9 2021 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- update to 3.4.1
+- revert allow psr/container v2
+
+* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 3.3.5-1
+- update to 3.3.5
+- switch to phpunit8
+- allow psr/container v2
+
+* Sun Jun 16 2019 Shawn Iwinski <shawn@iwin.ski> - 3.2.2-1
+- Update to 3.2.2 (RHBZ #1607388)
+
+* Sun Aug 20 2017 Shawn Iwinski <shawn@iwin.ski> - 2.4.1-1
+- Update to 2.4.1
+- Switch autoloader to fedora/autoloader
+- Test with SCLs if available
+
+* Tue Aug 09 2016 Shawn Iwinski <shawn@iwin.ski> - 2.2.0-1
+- Initial package