summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:40:14 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:40:14 +0200
commit7efcb8e403408e0a6a865b120fccf42de3be3c42 (patch)
treec27c01e63a9fe9359b589f8ee20e663b05936874
parente00a8953cd812230924374a8541dce714e3fb8d2 (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json53
-rwxr-xr-xphp-league-container-get-source.sh4
-rw-r--r--php-league-container.spec1
5 files changed, 68 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..8ce66c3
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,53 @@
+{
+ "name": "league/container",
+ "description": "A fast and intuitive dependency injection container.",
+ "keywords": [
+ "league",
+ "container",
+ "dependency",
+ "injection",
+ "di",
+ "service",
+ "provider"
+ ],
+ "homepage": "https://github.com/thephpleague/container",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Phil Bennett",
+ "email": "philipobenito@gmail.com",
+ "homepage": "http://www.philipobenito.com",
+ "role": "Developer"
+ }
+ ],
+ "require": {
+ "php": "^5.4.0 || ^7.0",
+ "container-interop/container-interop": "^1.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit" : "4.*"
+ },
+ "provide": {
+ "container-interop/container-interop-implementation": "^1.2",
+ "psr/container-implementation": "^1.0"
+ },
+ "replace": {
+ "orno/di": "~2.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Container\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "League\\Container\\Test\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-2.x": "2.x-dev",
+ "dev-1.x": "1.x-dev"
+ }
+ }
+}
diff --git a/php-league-container-get-source.sh b/php-league-container-get-source.sh
index ba71f5d..4ad1051 100755
--- a/php-league-container-get-source.sh
+++ b/php-league-container-get-source.sh
@@ -43,6 +43,8 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +53,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +61,6 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-league-container.spec b/php-league-container.spec
index 5141bb4..b4b85e1 100644
--- a/php-league-container.spec
+++ b/php-league-container.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-league-container
#
# Fedora spec file for php-league-container
#