summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-22 11:13:06 +0100
committerRemi Collet <remi@remirepo.net>2021-01-22 11:13:06 +0100
commita68955c5a73fd271f52317e06304dcd888905752 (patch)
tree9cf44451c31b1f495e6b46639aad7900f4cbbe46
parentb1d4ef9079e0c91f93acab4b15990602b1b07173 (diff)
update to 2.10.0
raise dependency on PHP 7.3 raise dependency on laminas-math 3.3.0 raise dependency on laminas-server 2.9.1 switch to phpunit9
-rw-r--r--composer.json14
-rw-r--r--php-laminas-xmlrpc.spec46
2 files changed, 32 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index 05b72bc..bb7b160 100644
--- a/composer.json
+++ b/composer.json
@@ -19,23 +19,19 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.9.x-dev",
- "dev-develop": "2.10.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-http": "^2.5.4",
- "laminas/laminas-math": "^2.7 || ^3.0",
- "laminas/laminas-server": "^2.7",
+ "laminas/laminas-math": "^3.3.0",
+ "laminas/laminas-server": "^2.9.1",
"laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-xml": "^1.0.2",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-cache": "To support Laminas\\XmlRpc\\Server\\Cache usage"
@@ -65,6 +61,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-xmlrpc": "self.version"
+ "zendframework/zend-xmlrpc": "^2.9.0"
}
}
diff --git a/php-laminas-xmlrpc.spec b/php-laminas-xmlrpc.spec
index e2e112a..3c6b54c 100644
--- a/php-laminas-xmlrpc.spec
+++ b/php-laminas-xmlrpc.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-xmlrpc
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1461f9777ec59f6c5dcbd727e23548ea1cbe4dcc
+%global gh_commit 58bd93719c495eef046f7a0209fa024e4a6b0816
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xmlrpc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-simplexml
BuildRequires: php-date
BuildRequires: php-dom
@@ -46,14 +46,14 @@ BuildRequires: php-xmlwriter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.7 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-server) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+# "phpunit/phpunit": "^9.3"
# remirepo:8
%else
BuildRequires: php-laminas-http
@@ -63,27 +63,27 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-xml
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-http": "^2.5.4",
-# "laminas/laminas-math": "^2.7 || ^3.0",
-# "laminas/laminas-server": "^2.7",
+# "laminas/laminas-math": "^3.3.0",
+# "laminas/laminas-server": "^2.9.1",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-xml": "^1.0.2",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-server) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -112,11 +112,12 @@ Requires: php-pcre
Requires: php-spl
Requires: php-xmlwriter
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.9.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.10.0
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -196,10 +197,10 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -219,6 +220,13 @@ exit $ret
%changelog
+* Fri Jan 22 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-math 3.3.0
+- raise dependency on laminas-server 2.9.1
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.9.0-1
- switch to Laminas