summaryrefslogtreecommitdiffstats
path: root/php-laminas-xml2json.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-xml2json.spec')
-rw-r--r--php-laminas-xml2json.spec56
1 files changed, 34 insertions, 22 deletions
diff --git a/php-laminas-xml2json.spec b/php-laminas-xml2json.spec
index a6cbfb1..07277ca 100644
--- a/php-laminas-xml2json.spec
+++ b/php-laminas-xml2json.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-xml2json
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e5bbd99e073b8c8b05f2675640fe8b339fcf05a3
+%global gh_commit 86ef887bd49e1bc0f2f32d2722ba777ae2e36df8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xml2json
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.1.2
-Release: 2%{?dist}
+Version: 3.2.0
+Release: 1%{?dist}
Summary: Provides functionality for converting XML to JSON
License: BSD
@@ -34,16 +34,17 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
+BuildRequires: php-simplexml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "laminas/laminas-coding-standard": "~2.0.0",
+# "phpunit/phpunit": "^9.4.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.3 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -51,23 +52,26 @@ BuildRequires: php-laminas-json
BuildRequires: php-laminas-xml
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.4.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-json": "^2.6.1 || ^3.0",
-# "laminas/laminas-xml": "^1.0.2",
+# "php": "^7.3 || ^8.0",
+# "ext-simplexml": "*",
+# "laminas/laminas-json": "^3.1",
+# "laminas/laminas-xml": "^1.3",
+# "laminas/laminas-zendframework-bridge": "^1.1"
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
+Requires: php-simplexml
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.3 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -78,13 +82,13 @@ Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 3.1.2
+# From phpcompatinfo report for version 3.2.0
Requires: php-pcre
Requires: php-spl
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.1.2-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.1.3
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -144,10 +148,10 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
@@ -174,6 +178,14 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- add dependency on simplexml extension
+- raise dependency on PHP 7.3
+- raise dependency on laminas-json 3.1
+- raise dependency on laminas-xml 1.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.1.2-2
- cleanup