summaryrefslogtreecommitdiffstats
path: root/php-laminas-xml2json.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-xml2json.spec')
-rw-r--r--php-laminas-xml2json.spec111
1 files changed, 71 insertions, 40 deletions
diff --git a/php-laminas-xml2json.spec b/php-laminas-xml2json.spec
index ca1c6f9..be35adb 100644
--- a/php-laminas-xml2json.spec
+++ b/php-laminas-xml2json.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-xml2json
+# remirepo/Fedora spec file for php-laminas-xml2json
#
# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 43b08ce4b8350a9c0296d134a50f8e7c6e59b6cf
+%global gh_commit e5bbd99e073b8c8b05f2675640fe8b339fcf05a3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-xml2json
+%global gh_owner laminas
+%global gh_project laminas-xml2json
+%global zf_name zend-xml2json
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Xml2Json
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 3.1.2
Release: 1%{?dist}
Summary: Provides functionality for converting XML to JSON
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -36,60 +38,63 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
-# remirepo:8
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:5
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zendxml) < 2
-BuildRequires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-json
+BuildRequires: php-laminas-xml
+BuildRequires: php-laminas-zendframework-bridge
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-json": "^2.6.1 || ^3.0",
-# "zendframework/zendxml": "^1.0.2"
+# "laminas/laminas-json": "^2.6.1 || ^3.0",
+# "laminas/laminas-xml": "^1.0.2",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
-# remirepo:6
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-xml) >= 1.0.2 with php-autoloader(%{gh_owner}/laminas-xml) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:5
%else
-Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
-Requires: php-autoloader(%{gh_owner}/zend-json) < 4
-Requires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
-Requires: php-autoloader(%{gh_owner}/zendxml) < 2
+Requires: php-laminas-json
+Requires: php-laminas-xml
+Requires: php-laminas-zendframework-bridge
%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 3.0.0
+# From phpcompatinfo report for version 3.1.2
Requires: php-pcre
Requires: php-spl
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.1.2-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-zend-xml2json provides functionality for converting XML structures to JSON.
+%{gh_project} provides functionality for converting XML structures to JSON.
-* File issues at https://github.com/zendframework/zend-xml2json/issues
-* Documentation is at https://zendframework.github.io/zend-xml2json/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -103,15 +108,29 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Json/autoload.php',
- '%{php_home}/ZendXml/autoload.php',
+ '%{php_home}/%{namespace}/Json/autoload.php',
+ '%{php_home}/%{namespace}/Xml/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -119,17 +138,25 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -143,9 +170,13 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Wed Jan 8 2020 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- switch to Laminas
+
* Wed Oct 16 2019 Remi Collet <remi@remirepo.net> - 3.1.2-1
- update to 3.1.2