summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rw-r--r--php-laminas-xml2json.spec21
2 files changed, 17 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index aa003e5..9576f6d 100644
--- a/composer.json
+++ b/composer.json
@@ -23,12 +23,11 @@
"php": "^7.3 || ^8.0",
"ext-simplexml": "*",
"laminas/laminas-json": "^3.1",
- "laminas/laminas-xml": "^1.3",
- "laminas/laminas-zendframework-bridge": "^1.1"
+ "laminas/laminas-xml": "^1.3"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.0.0",
- "phpunit/phpunit": "^9.4.4"
+ "laminas/laminas-coding-standard": "^2.3",
+ "phpunit/phpunit": "^9.5"
},
"autoload": {
"psr-4": {
@@ -50,7 +49,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-xml2json": "^3.1.2"
+ "conflict": {
+ "zendframework/zend-xml2json": "*"
}
}
diff --git a/php-laminas-xml2json.spec b/php-laminas-xml2json.spec
index 07277ca..c20c35b 100644
--- a/php-laminas-xml2json.spec
+++ b/php-laminas-xml2json.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 86ef887bd49e1bc0f2f32d2722ba777ae2e36df8
+%global gh_commit ad218864216b7a8a83add20c6f5ec0320d56dbf4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xml2json
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
+Version: 3.3.0
Release: 1%{?dist}
Summary: Provides functionality for converting XML to JSON
@@ -39,8 +39,8 @@ BuildRequires: php-simplexml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.0.0",
-# "phpunit/phpunit": "^9.4.4"
+# "laminas/laminas-coding-standard": "^2.3",
+# "phpunit/phpunit": "^9.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
@@ -53,7 +53,7 @@ BuildRequires: php-laminas-xml
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4.4
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -62,9 +62,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^7.3 || ^8.0",
# "ext-simplexml": "*",
# "laminas/laminas-json": "^3.1",
-# "laminas/laminas-xml": "^1.3",
-# "laminas/laminas-zendframework-bridge": "^1.1"
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-xml": "^1.3"
Requires: php(language) >= 7.3
Requires: php-simplexml
%if ! %{bootstrap}
@@ -148,7 +146,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -178,6 +176,11 @@ exit $ret
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- add dependency on simplexml extension