summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-30 07:42:46 +0100
committerRemi Collet <remi@php.net>2021-11-30 07:42:46 +0100
commit8780d66ea33fd0cc68b00fe02f01a81e18169978 (patch)
treefb5e8c9f5db4870a543c7582b5c65344d92fa9d8
parenteaea3e35fe0e85f12132bd994b50d02e0e1e3435 (diff)
update to 1.4.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json14
-rw-r--r--php-laminas-xml.spec25
2 files changed, 23 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 44b5fe2..e7f0e1b 100644
--- a/composer.json
+++ b/composer.json
@@ -18,15 +18,15 @@
"config": {
"sort-packages": true
},
- "extra": {
- },
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "ext-dom": "*",
+ "ext-simplexml": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.4",
+ "squizlabs/php_codesniffer": "3.6.1 as 2.9999999.9999999",
+ "phpunit/phpunit": "^9.5.8",
"ext-iconv": "*"
},
"autoload": {
@@ -49,7 +49,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zendxml": "^1.2.0"
+ "conflict": {
+ "zendframework/zendxml": "*"
}
}
diff --git a/php-laminas-xml.spec b/php-laminas-xml.spec
index 2dace6f..0d5f70a 100644
--- a/php-laminas-xml.spec
+++ b/php-laminas-xml.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2eada592359aec9d9e55339270b621295cff3a4f
+%global gh_commit dcadeefdb6d7ed6b39d772b47e3845003d6ea60f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-xml
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.1
+Version: 1.4.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -48,18 +48,22 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.4",
+# "squizlabs/php_codesniffer": "3.6.1 as 2.9999999.9999999",
+# "phpunit/phpunit": "^9.5.8",
# "ext-iconv": "*"
-BuildRequires: phpunit9 >= 9.4
+BuildRequires: phpunit9 >= 9.5.8
BuildRequires: php-iconv
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "ext-dom": "*",
+# "ext-simplexml": "*"
Requires: php(language) >= 7.3
+Requires: php-dom
+Requires: php-simplexml
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -68,8 +72,6 @@ Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
Requires: php-laminas-zendframework-bridge
%endif
# From phpcompatinfo report for version 1.3.0
-Requires: php-simplexml
-Requires: php-dom
Requires: php-libxml
Requires: php-pcre
# Autoloader
@@ -133,7 +135,7 @@ EOF
: upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -162,6 +164,11 @@ exit $ret
%changelog
+* Tue Nov 30 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 1.3.1-1
- update to 1.3.1 (no change)