summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-laminas-view.spec21
1 files changed, 10 insertions, 11 deletions
diff --git a/php-laminas-view.spec b/php-laminas-view.spec
index ef504e6..f02b574 100644
--- a/php-laminas-view.spec
+++ b/php-laminas-view.spec
@@ -19,7 +19,7 @@
Name: php-%{gh_project}
Version: 2.20.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -39,12 +39,11 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(psr/container) >= 1 with php-composer(psr/container) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -89,7 +88,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
BuildRequires: (php-composer(phpspec/prophecy) >= 1.12.0 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:30
+# remirepo:29
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-json
@@ -117,7 +116,6 @@ BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-uri
BuildRequires: php-phpspec-prophecy
BuildRequires: php-phpspec-prophecy-phpunit
-BuildRequires: php-container-interop
BuildRequires: php-psr-container2
%endif
BuildRequires: phpunit9 >= 9.5.5
@@ -144,12 +142,11 @@ Requires: php-filter
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-composer(psr/container) >= 1 with php-composer(psr/container) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -178,7 +175,7 @@ Suggests: php-composer(%{gh_owner}/laminas-navigation)
Suggests: php-composer(%{gh_owner}/laminas-paginator)
Suggests: php-composer(%{gh_owner}/laminas-permissions-acl)
Suggests: php-composer(%{gh_owner}/laminas-uri)
-# remirepo:11
+# remirepo:10
%else
Requires: php-laminas-escaper
Requires: php-laminas-eventmanager
@@ -187,7 +184,6 @@ Requires: php-laminas-loader
Requires: php-laminas-servicemanager
Requires: php-laminas-stdlib
Requires: php-laminas-zendframework-bridge
-Requires: php-container-interop
Requires: php-psr-container2
%endif
# Autoloader
@@ -230,7 +226,7 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
[
'%{php_home}/Psr/Container2/autoload.php',
'%{php_home}/Psr/Container/autoload.php',
@@ -238,7 +234,6 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/%{namespace}/Escaper/autoload.php',
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Loader/autoload.php',
- '%{php_home}/%{namespace}/ServiceManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
@@ -338,6 +333,10 @@ exit $ret
%changelog
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 2.20.0-2
+- drop dependency on container-interop/container-interop
+ replaced by servicemanager >= 3.12
+
* Wed Mar 30 2022 Remi Collet <remi@remirepo.net> - 2.20.0-1
- update to 2.20.0
- add dependency on laminas-escaper, laminas-servicemanager,