summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-16 06:41:30 +0100
committerRemi Collet <remi@remirepo.net>2020-12-16 06:41:30 +0100
commit21d9b4ef0cf60a8141f43e23720195ef1737db16 (patch)
treeb041abd4cdca01006caab5e84e23fbf5241db683
parenta7cbd3f4315557cc462e06c7fcfe7d448a15e977 (diff)
update to 2.11.5
switch to phpunit7
-rw-r--r--composer.json8
-rw-r--r--php-laminas-view.spec26
2 files changed, 18 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index c49a4cc..37d991e 100644
--- a/composer.json
+++ b/composer.json
@@ -19,10 +19,6 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.11.x-dev",
- "dev-develop": "2.12.x-dev"
- }
},
"require": {
"php": "^5.6 || ^7.0",
@@ -54,7 +50,7 @@
"laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
"laminas/laminas-session": "^2.8.1",
"laminas/laminas-uri": "^2.5",
- "phpunit/phpunit": "^5.7.15 || ^6.0.8"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.18"
},
"suggest": {
"laminas/laminas-authentication": "Laminas\\Authentication component",
@@ -98,6 +94,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-view": "self.version"
+ "zendframework/zend-view": "^2.11.4"
}
}
diff --git a/php-laminas-view.spec b/php-laminas-view.spec
index c4480c8..4bf7148 100644
--- a/php-laminas-view.spec
+++ b/php-laminas-view.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 1
-%global gh_commit 3bbb2e94287383604c898284a18d2d06cf17301e
+%global gh_commit 16611035d7b3a6ef2c636a9268c213146123b663
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-view
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.11.4
+Version: 2.11.5
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -66,7 +66,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
# "laminas/laminas-session": "^2.8.1",
# "laminas/laminas-uri": "^2.5",
-# "phpunit/phpunit": "^5.7.15 || ^6.0.8"
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.18"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-authentication) >= 2.5 with php-autoloader(%{gh_owner}/laminas-authentication) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
@@ -82,14 +82,14 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.7.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-navigation) >= 2.5 with php-autoloader(%{gh_owner}/laminas-navigation) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-paginator) >= 2.5 with php-autoloader(%{gh_owner}/laminas-paginator) < 3)
-%endif
BuildRequires: (php-autoloader(%{gh_owner}/laminas-permissions-acl) >= 2.6 with php-autoloader(%{gh_owner}/laminas-permissions-acl) < 3)
+%endif
BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.1 with php-autoloader(%{gh_owner}/laminas-router) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-serializer) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-# remirepo:26
+# remirepo:28
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-json
@@ -110,15 +110,15 @@ BuildRequires: php-laminas-modulemanager
BuildRequires: php-laminas-mvc
BuildRequires: php-laminas-navigation
BuildRequires: php-laminas-paginator
-%endif
BuildRequires: php-laminas-permissions-acl
+%endif
BuildRequires: php-laminas-router
BuildRequires: php-laminas-serializer
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-session
BuildRequires: php-laminas-uri
%endif
-BuildRequires: phpunit6
+BuildRequires: phpunit7 >= 7.5.18
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -184,11 +184,12 @@ Requires: php-filter
Requires: php-pcre
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.11.4-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.11.5
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -297,7 +298,7 @@ rm -r test/Helper*
ret=0
for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
done
exit $ret
@@ -307,6 +308,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -317,6 +319,10 @@ exit $ret
%changelog
+* Wed Dec 16 2020 Remi Collet <remi@remirepo.net> - 2.11.5-1
+- update to 2.11.5
+- switch to phpunit7
+
* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 2.11.4-1
- switch to Laminas