summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-20 16:30:10 +0200
committerRemi Collet <remi@php.net>2022-09-20 16:30:10 +0200
commitf267b44907683cc89a93845af5e186a9e602e201 (patch)
treed5559fb73f45c254d71ad6e10d39babf2fd7e486
parente7b111853308a1b0709372978cc603c6f17a7cb3 (diff)
update to 2.23.0HEADmaster
-rw-r--r--composer.json18
-rw-r--r--php-laminas-validator.spec45
2 files changed, 34 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 3c552aa..715d2b7 100644
--- a/composer.json
+++ b/composer.json
@@ -33,23 +33,23 @@
"require": {
"php": "^7.4 || ~8.0.0 || ~8.1.0",
"laminas/laminas-servicemanager": "^3.12.0",
- "laminas/laminas-stdlib": "^3.10"
+ "laminas/laminas-stdlib": "^3.13"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
- "laminas/laminas-db": "^2.7",
- "laminas/laminas-filter": "^2.14.0",
- "laminas/laminas-http": "^2.14.2",
- "laminas/laminas-i18n": "^2.15.0",
- "laminas/laminas-session": "^2.12.1",
+ "laminas/laminas-coding-standard": "^2.4.0",
+ "laminas/laminas-db": "^2.15.0",
+ "laminas/laminas-filter": "^2.18.0",
+ "laminas/laminas-http": "^2.16.0",
+ "laminas/laminas-i18n": "^2.17.0",
+ "laminas/laminas-session": "^2.13.0",
"laminas/laminas-uri": "^2.9.1",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5.21",
+ "phpunit/phpunit": "^9.5.24",
"psalm/plugin-phpunit": "^0.17.0",
"psr/http-client": "^1.0",
"psr/http-factory": "^1.0",
"psr/http-message": "^1.0",
- "vimeo/psalm": "^4.24.0"
+ "vimeo/psalm": "^4.27.0"
},
"suggest": {
"laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index f183f23..67fbc1d 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -8,7 +8,7 @@
#
# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit 6d61b6cc3b222f13807a18d9247cdfb084958b03
+%global gh_commit 42de39b78e73b321db7d948cf8530a2764f8b9aa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.23.0
+Version: 2.25.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,29 +42,29 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.13 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.2.1",
-# "laminas/laminas-db": "^2.7",
-# "laminas/laminas-filter": "^2.14.0",
-# "laminas/laminas-http": "^2.14.2",
-# "laminas/laminas-i18n": "^2.15.0",
-# "laminas/laminas-session": "^2.12.1",
+# "laminas/laminas-coding-standard": "^2.4.0",
+# "laminas/laminas-db": "^2.15.0",
+# "laminas/laminas-filter": "^2.18.0",
+# "laminas/laminas-http": "^2.16.0",
+# "laminas/laminas-i18n": "^2.17.0",
+# "laminas/laminas-session": "^2.13.0",
# "laminas/laminas-uri": "^2.9.1",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5.21",
+# "phpunit/phpunit": "^9.5.24",
# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
# "psr/http-message": "^1.0",
-# "vimeo/psalm": "^4.24.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.15.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+# "vimeo/psalm": "^4.27.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.17.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.14.0 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14.2 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.12.1 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.15 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.18 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.16 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.13 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
%endif
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
@@ -90,7 +90,7 @@ BuildRequires: php-psr-http-client
BuildRequires: php-psr-http-factory
BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit9 >= 9.5.21
+BuildRequires: phpunit9 >= 9.5.24
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -98,12 +98,12 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-servicemanager": "^3.12.0",
-# "laminas/laminas-stdlib": "^3.10"
+# "laminas/laminas-stdlib": "^3.13"
Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.13 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
@@ -241,7 +241,8 @@ exit (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php74 php80 php81 php82; do
+# TODO php82 (Trying to access array offset on value of type bool)
+for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -263,6 +264,10 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.25.0-1
+- update to 2.25.0
+- raise dependency on zend-stdlib >= 3.13
+
* Thu Jul 28 2022 Remi Collet <remi@remirepo.net> - 2.23.0-1
- update to 2.23.0