summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-09 14:48:02 +0200
committerRemi Collet <remi@php.net>2022-06-09 14:48:02 +0200
commitc9167aa263dd1e70eacaaec867eb34c06b8eded0 (patch)
treeeac9c06b0033f6c127417788a23f3f8aca31cdf3
parent7158affff49b1c547862ad6fc78c5e4e06589328 (diff)
update to 2.18.0
raise dependency on zend-stdlib >= 3.10
-rw-r--r--composer.json5
-rw-r--r--php-laminas-validator.spec16
2 files changed, 14 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 3a4c672..47e28d9 100644
--- a/composer.json
+++ b/composer.json
@@ -19,6 +19,9 @@
"sort-packages": true,
"platform": {
"php": "7.3.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
}
},
"extra": {
@@ -30,7 +33,7 @@
"require": {
"php": "^7.3 || ~8.0.0 || ~8.1.0",
"container-interop/container-interop": "^1.1",
- "laminas/laminas-stdlib": "^3.6"
+ "laminas/laminas-stdlib": "^3.10"
},
"require-dev": {
"laminas/laminas-cache": "^2.6.1",
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index 71c1afa..d0ed947 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -8,7 +8,7 @@
#
# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit bdd503adc83d814a5c94e598ea0eb9fc7ca56339
+%global gh_commit dd9d10602048c561730d8bdb0ae589cd8ba11a82
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.17.0
+Version: 2.18.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,7 +42,7 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-cache": "^2.6.1",
@@ -107,12 +107,12 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "container-interop/container-interop": "^1.1",
-# "laminas/laminas-stdlib": "^3.6"
+# "laminas/laminas-stdlib": "^3.10"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
@@ -253,7 +253,7 @@ exit (class_exists("\\Zend\\%{library}\\Hex") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php74 php80 php81; do
+for cmd in php php74 php80 php81 php82; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -275,6 +275,10 @@ exit $ret
%changelog
+* Thu Jun 9 2022 Remi Collet <remi@remirepo.net> - 2.18.0-1
+- update to 2.18.0
+- raise dependency on zend-stdlib >= 3.10
+
* Wed Mar 9 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
- update to 2.17.0