summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-14 15:23:11 +0100
committerRemi Collet <remi@php.net>2022-12-14 15:23:11 +0100
commitc3a95f5227935682f95c456f1ec2c7f6b16e95b7 (patch)
tree40d0ee7de40ba051d0018e190fbd02aaf2b407a3
parent0957fd75a1a480533a5236c5c4e1738a43cebb39 (diff)
update to 2.29.0
-rw-r--r--composer.json14
-rw-r--r--php-laminas-validator.spec29
2 files changed, 23 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index b995fcf..ce70ff1 100644
--- a/composer.json
+++ b/composer.json
@@ -38,17 +38,17 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "^2.4.0",
- "laminas/laminas-db": "^2.15.0",
- "laminas/laminas-filter": "^2.23.0",
- "laminas/laminas-http": "^2.17.0",
+ "laminas/laminas-db": "^2.16",
+ "laminas/laminas-filter": "^2.28.1",
+ "laminas/laminas-http": "^2.18",
"laminas/laminas-i18n": "^2.19",
- "laminas/laminas-session": "^2.13.0",
+ "laminas/laminas-session": "^2.15",
"laminas/laminas-uri": "^2.10.0",
- "phpunit/phpunit": "^9.5.25",
- "psalm/plugin-phpunit": "^0.18.0",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.3",
"psr/http-client": "^1.0.1",
"psr/http-factory": "^1.0.1",
- "vimeo/psalm": "^4.28"
+ "vimeo/psalm": "^5.0"
},
"suggest": {
"laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index 5d35516..ed97866 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -8,7 +8,7 @@
#
# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit 695bfa40b0a83dc1c5c58bdf74a03fdbeb516c39
+%global gh_commit e40ee8d86cc1907083e273bfd6ed8b6dde2d9850
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,11 +19,11 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.28.0
+Version: 2.29.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -47,22 +47,22 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "^2.4.0",
-# "laminas/laminas-db": "^2.15.0",
-# "laminas/laminas-filter": "^2.23.0",
-# "laminas/laminas-http": "^2.17.0",
+# "laminas/laminas-db": "^2.16",
+# "laminas/laminas-filter": "^2.28.1",
+# "laminas/laminas-http": "^2.18",
# "laminas/laminas-i18n": "^2.19",
# "laminas/laminas-session": "^2.13.0",
# "laminas/laminas-uri": "^2.10.0",
-# "phpunit/phpunit": "^9.5.25",
-# "psalm/plugin-phpunit": "^0.18.0",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.3",
# "psr/http-client": "^1.0.1",
# "psr/http-factory": "^1.0.1",
-# "vimeo/psalm": "^4.28"
+# "vimeo/psalm": "^5.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.19 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.15 with php-autoloader(%{gh_owner}/laminas-db) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.23 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.17 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.16 with php-autoloader(%{gh_owner}/laminas-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.28.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.18 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.13 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.10 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
%endif
@@ -86,7 +86,7 @@ BuildRequires: php-psr-http-message
BuildRequires: php-psr-http-client
BuildRequires: php-psr-http-factory
%endif
-BuildRequires: phpunit9 >= 9.5.25
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -259,6 +259,9 @@ exit $ret
%changelog
+* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 2.29.0-1
+- update to 2.29.0
+
* Mon Nov 14 2022 Remi Collet <remi@remirepo.net> - 2.28.0-1
- update to 2.28.0
- add mandatory dependency on psr/http-message