summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-25 14:21:07 +0200
committerRemi Collet <remi@php.net>2022-07-25 14:21:07 +0200
commita43d428d41e7d372f741cc945233bd875136eeb8 (patch)
treee87c4655176a539f12628ed7b54763b115c657d1
parentabb1a5d47cf228a8707a25fd706cd334f5a2ce16 (diff)
update to 2.22.0
-rw-r--r--composer.json9
-rw-r--r--php-laminas-validator.spec20
2 files changed, 14 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 5a9deb5..3c552aa 100644
--- a/composer.json
+++ b/composer.json
@@ -36,8 +36,7 @@
"laminas/laminas-stdlib": "^3.10"
},
"require-dev": {
- "laminas/laminas-cache": "^2.6.1",
- "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-db": "^2.7",
"laminas/laminas-filter": "^2.14.0",
"laminas/laminas-http": "^2.14.2",
@@ -45,12 +44,12 @@
"laminas/laminas-session": "^2.12.1",
"laminas/laminas-uri": "^2.9.1",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5.5",
- "psalm/plugin-phpunit": "^0.15.0",
+ "phpunit/phpunit": "^9.5.21",
+ "psalm/plugin-phpunit": "^0.17.0",
"psr/http-client": "^1.0",
"psr/http-factory": "^1.0",
"psr/http-message": "^1.0",
- "vimeo/psalm": "^4.23"
+ "vimeo/psalm": "^4.24.0"
},
"suggest": {
"laminas/laminas-db": "Laminas\\Db component, required by the (No)RecordExists validator",
diff --git a/php-laminas-validator.spec b/php-laminas-validator.spec
index a05571c..ffe4d44 100644
--- a/php-laminas-validator.spec
+++ b/php-laminas-validator.spec
@@ -8,7 +8,7 @@
#
# When buid without db, filter, http, session, uri
%global bootstrap 0
-%global gh_commit 90304417929a51e42999b115907a39f4b658c131
+%global gh_commit 7baf6c147f776a05cff280f4e5a676118f0f5198
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-validator
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.20.1
+Version: 2.22.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -45,7 +45,6 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-cache": "^2.6.1",
# "laminas/laminas-coding-standard": "~2.2.1",
# "laminas/laminas-db": "^2.7",
# "laminas/laminas-filter": "^2.14.0",
@@ -54,13 +53,12 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-session": "^2.12.1",
# "laminas/laminas-uri": "^2.9.1",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5.5",
-# "psalm/plugin-phpunit": "^0.15.0",
+# "phpunit/phpunit": "^9.5.21",
+# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-client": "^1.0",
# "psr/http-factory": "^1.0",
# "psr/http-message": "^1.0",
-# "vimeo/psalm": "^4.3"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+# "vimeo/psalm": "^4.24.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.15.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
%if ! %{bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
@@ -73,12 +71,11 @@ BuildRequires: (php-composer(psr/http-message) >= 1.0
BuildRequires: (php-composer(psr/http-client) >= 1.0 with php-composer(psr/http-client) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:19
+# remirepo:18
%else
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-cache
BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-servicemanager
%if ! %{bootstrap}
@@ -93,7 +90,7 @@ BuildRequires: php-psr-http-client
BuildRequires: php-psr-http-factory
BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.21
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -266,6 +263,9 @@ exit $ret
%changelog
+* Mon Jul 25 2022 Remi Collet <remi@remirepo.net> - 2.22.0-1
+- update to 2.22.0
+
* Fri Jul 1 2022 Remi Collet <remi@remirepo.net> - 2.20.1-1
- update to 2.20.1 (no change)