summaryrefslogtreecommitdiffstats
path: root/php-laminas-text.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-text.spec')
-rw-r--r--php-laminas-text.spec33
1 files changed, 18 insertions, 15 deletions
diff --git a/php-laminas-text.spec b/php-laminas-text.spec
index 8d86780..dc1353a 100644
--- a/php-laminas-text.spec
+++ b/php-laminas-text.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-text
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 76fccc8f79a6fb61689e96ab300566c0065deaaa
+%global gh_commit 8879e75d03e09b0d6787e6680cfa255afd4645a7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-text
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -40,20 +40,17 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^3.4",
# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-# remirepo:6
+# remirepo:5
%else
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config3
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.3
@@ -62,16 +59,16 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-servicemanager": "^3.4",
-# "laminas/laminas-stdlib": "^3.1",
+# "laminas/laminas-stdlib": "^3.6",
# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -159,9 +156,6 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/Config3/autoload.php',
-]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -173,7 +167,7 @@ exit (class_exists("\\Zend\\%{library}\\MultiByte") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -196,6 +190,15 @@ exit $ret
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on zend-stdlib >= 3.6
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.1-1
+- update to 2.8.1 (no change)
+
* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0 (no change)
- raise dependency on PHP 7.3