summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-02 10:09:49 +0100
committerRemi Collet <remi@remirepo.net>2020-11-02 10:09:49 +0100
commit5d5cfceae62bff8363a550fee231cfb37f1d2d1c (patch)
tree549828b18d03a831977940bbc8ad15daffe54a0a
parentd935b8e7ee771566ec4fbe68b930a6bf1a92f634 (diff)
update to 2.8.0 (no change)HEADmaster
raise dependency on PHP 7.3 raise dependency on laminas-servicemanager 3.4 raise dependency on zend-stdlib >= 3.1 switch to phpunit9
-rw-r--r--composer.json16
-rw-r--r--php-laminas-text.spec53
2 files changed, 36 insertions, 33 deletions
diff --git a/composer.json b/composer.json
index 5b0bb29..0751fd9 100644
--- a/composer.json
+++ b/composer.json
@@ -19,21 +19,17 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-servicemanager": "^3.4",
+ "laminas/laminas-stdlib": "^3.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-config": "^2.6",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "laminas/laminas-config": "^3.4",
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"psr-4": {
@@ -59,6 +55,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-text": "self.version"
+ "zendframework/zend-text": "^2.7.1"
}
}
diff --git a/php-laminas-text.spec b/php-laminas-text.spec
index 8f587b5..8d86780 100644
--- a/php-laminas-text.spec
+++ b/php-laminas-text.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3601b5eacb06ed0a12f658df860cc0f9613cf4db
+%global gh_commit 76fccc8f79a6fb61689e96ab300566c0065deaaa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-text
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.1
-Release: 2%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -34,44 +34,44 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^2.6",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "laminas/laminas-config": "^3.4",
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
# remirepo:6
%else
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config
+BuildRequires: php-laminas-config3
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-servicemanager": "^3.4",
+# "laminas/laminas-stdlib": "^3.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:5
%else
@@ -91,8 +91,8 @@ Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.7.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.7.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -160,7 +160,7 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config3/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -173,10 +173,10 @@ exit (class_exists("\\Zend\\%{library}\\MultiByte") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -196,6 +196,13 @@ exit $ret
%changelog
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0 (no change)
+- raise dependency on PHP 7.3
+- raise dependency on laminas-servicemanager 3.4
+- raise dependency on zend-stdlib >= 3.1
+- switch to phpunit9
+
* Sat Jan 25 2020 Remi Collet <remi@remirepo.net> - 2.7.1-2
- fix Package obsoletes itself #1792401