summaryrefslogtreecommitdiffstats
path: root/php-laminas-test.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-test.spec')
-rw-r--r--php-laminas-test.spec56
1 files changed, 33 insertions, 23 deletions
diff --git a/php-laminas-test.spec b/php-laminas-test.spec
index 448866b..0a2f111 100644
--- a/php-laminas-test.spec
+++ b/php-laminas-test.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-test
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,7 +23,7 @@
Name: php-%{gh_project}
Version: 3.4.2
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -37,7 +37,6 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: phpunit
-BuildRequires: phpunit6
BuildRequires: phpunit7
BuildRequires: phpunit8
BuildRequires: phpunit9
@@ -254,26 +253,34 @@ exit (class_exists("\\Zend\\%{library}\\Util\ModuleLoader") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
- fi
-done
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 --verbose || ret=1
- fi
-done
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit8 --verbose || ret=1
- fi
-done
+if [ -x %{_bindir}/phpunit ]; then
+ for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+ done
+fi
+if [ -x %{_bindir}/phpunit6 ]; then
+ for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+ done
+fi
+if [ -x %{_bindir}/phpunit7 ]; then
+ for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ fi
+ done
+fi
+if [ -x %{_bindir}/phpunit ]; then
+ for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+ done
+fi
if [ -x %{_bindir}/phpunit9 ]; then
for cmd in php php73 php74; do
if which $cmd; then
@@ -298,6 +305,9 @@ exit $ret
%changelog
+* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 3.4.2-4
+- drop phpunit6 build dependency
+
* Fri May 22 2020 Remi Collet <remi@remirepo.net> - 3.4.2-1
- update to 3.4.2