summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-03 10:53:02 +0200
committerRemi Collet <remi@remirepo.net>2021-08-03 10:53:02 +0200
commit9950edb163c3fe72e307839329d3fdaf0e0b30d9 (patch)
tree5a260e7d96f9d5b0438cf6331479e41523ce9d05
parent057d9a73d8ad05db72f46ed72dfe871ca64ea428 (diff)
add fix for laminas-escaper 2.8.0
https://github.com/laminas/laminas-tag/pull/6
-rw-r--r--php-laminas-tag-escaper.patch22
-rw-r--r--php-laminas-tag.spec12
2 files changed, 32 insertions, 2 deletions
diff --git a/php-laminas-tag-escaper.patch b/php-laminas-tag-escaper.patch
new file mode 100644
index 0000000..fed770c
--- /dev/null
+++ b/php-laminas-tag-escaper.patch
@@ -0,0 +1,22 @@
+From d864af14cf8645f5ab09df9cd406b4eafd113a57 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 3 Aug 2021 10:36:00 +0200
+Subject: [PATCH] fix for laminas/escaper 2.8
+
+---
+ src/Cloud/Decorator/HtmlTag.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Cloud/Decorator/HtmlTag.php b/src/Cloud/Decorator/HtmlTag.php
+index 6e50578..89ab75b 100644
+--- a/src/Cloud/Decorator/HtmlTag.php
++++ b/src/Cloud/Decorator/HtmlTag.php
+@@ -241,7 +241,7 @@ public function render($tags)
+
+ $tagHTML = sprintf(
+ '<a href="%s" %s>%s</a>',
+- $escaper->escapeHtml($tag->getParam('url')),
++ $escaper->escapeHtml($tag->getParam('url') ?? ''),
+ $attribute,
+ $escaper->escapeHtml($tag->getTitle())
+ );
diff --git a/php-laminas-tag.spec b/php-laminas-tag.spec
index 8a1ddf8..d5888bc 100644
--- a/php-laminas-tag.spec
+++ b/php-laminas-tag.spec
@@ -23,7 +23,7 @@
Name: php-%{gh_project}
Version: 2.8.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -31,6 +31,9 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+# https://github.com/laminas/laminas-tag/pull/6
+Patch0: %{name}-escaper.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -110,6 +113,7 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -157,7 +161,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -187,6 +191,10 @@ exit $ret
%changelog
+* Tue Aug 3 2021 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- add fix for laminas-escaper 2.8.0
+ https://github.com/laminas/laminas-tag/pull/6
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0 (no change)
- raise dependency on PHP 7.3