summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-17 16:21:45 +0100
committerRemi Collet <remi@remirepo.net>2020-01-17 16:21:45 +0100
commitb007912edc0f62565a46ed313edd8620f08e9b25 (patch)
treea70971b4ed9e17703c431a364ec300b5472f6323
parent2ab93e9758260e69b50806db3615923e24fe13aa (diff)
switch to Laminas
-rw-r--r--composer.json129
-rw-r--r--php-laminas-stratigility.spec167
2 files changed, 169 insertions, 127 deletions
diff --git a/composer.json b/composer.json
index b56db26..99d6a48 100644
--- a/composer.json
+++ b/composer.json
@@ -1,57 +1,78 @@
{
- "name": "zendframework/zend-stratigility",
- "description": "Middleware for PHP",
- "type": "library",
- "license": "BSD-3-Clause",
- "keywords": [
- "http",
- "psr-7",
- "middleware"
- ],
- "homepage": "https://github.com/zendframework/zend-stratigility",
- "support": {
- "issues": "https://github.com/zendframework/zend-stratigility/issues",
- "source": "https://github.com/zendframework/zend-stratigility"
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.3.0-dev",
- "dev-develop": "2.0.0-dev"
- }
- },
- "require": {
- "php": "^5.6 || ^7.0",
- "psr/http-message": "^1.0",
- "zendframework/zend-escaper": "^2.3",
- "http-interop/http-middleware": "^0.2.0"
- },
- "require-dev": {
- "zendframework/zend-diactoros": "^1.0",
- "phpunit/phpunit": "^5.6",
- "zendframework/zend-coding-standard": "~1.0.0"
- },
- "suggest": {
- "psr/http-message-implementation": "Please install a psr/http-message-implementation to consume Stratigility; e.g., zendframework/zend-diactoros"
- },
- "autoload": {
- "psr-4": {
- "Zend\\Stratigility\\": "src/"
- }
- },
- "autoload-dev": {
- "psr-4": {
- "ZendTest\\Stratigility\\": "test/"
- }
- },
- "scripts": {
- "check": [
- "@cs-check",
- "@test"
+ "name": "laminas/laminas-stratigility",
+ "description": "Middleware for PHP",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "laminas",
+ "http",
+ "psr-7",
+ "middleware"
],
- "upload-coverage": "coveralls -v",
- "cs-check": "phpcs --colors",
- "cs-fix": "phpcbf --colors",
- "test": "phpunit --colors=always",
- "test-coverage": "phpunit --coverage-clover clover.xml"
- }
+ "homepage": "https://laminas.dev",
+ "support": {
+ "docs": "https://docs.laminas.dev/laminas-stratigility/",
+ "issues": "https://github.com/laminas/laminas-stratigility/issues",
+ "source": "https://github.com/laminas/laminas-stratigility",
+ "rss": "https://github.com/laminas/laminas-stratigility/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.2.x-dev",
+ "dev-develop": "3.0.x-dev"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "laminas/laminas-escaper": "^2.3",
+ "laminas/laminas-zendframework-bridge": "^1.0",
+ "psr/http-message": "^1.0",
+ "webimpress/http-middleware-compatibility": "^0.1.4"
+ },
+ "require-dev": {
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-diactoros": "^1.0",
+ "malukenho/docheader": "^0.1.5",
+ "phpunit/phpunit": "^5.7.22 || ^6.4.1"
+ },
+ "suggest": {
+ "psr/http-message-implementation": "Please install a psr/http-message-implementation to consume Stratigility; e.g., laminas/laminas-diactoros"
+ },
+ "autoload": {
+ "files": [
+ "src/functions/double-pass-middleware.php",
+ "src/functions/middleware.php",
+ "src/functions/path.php",
+ "src/functions/double-pass-middleware.legacy.php",
+ "src/functions/middleware.legacy.php",
+ "src/functions/path.legacy.php"
+ ],
+ "psr-4": {
+ "Laminas\\Stratigility\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "LaminasTest\\Stratigility\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@license-check",
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "license-check": "docheader check src/ test/",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-stratigility": "self.version"
+ }
}
diff --git a/php-laminas-stratigility.spec b/php-laminas-stratigility.spec
index d591c9b..860357c 100644
--- a/php-laminas-stratigility.spec
+++ b/php-laminas-stratigility.spec
@@ -1,17 +1,19 @@
-# remirepo/Fedora spec file for php-zendframework-zend-stratigility
+# remirepo/Fedora spec file for stratigility
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
-%global gh_commit 2c4120d2af215c8261a36e0bc3aa8e179e05e148
+%global bootstrap 0
+%global gh_commit a1918566361aada1b7a56ac206e2f2ac697a204a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-stratigility
+%global gh_owner laminas
+%global gh_project laminas-stratigility
+%global zf_name zend-stratigility
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Stratigility
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,97 +21,90 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
-Version: 1.3.3
-Release: 7%{?dist}
+Name: php-%{gh_project}
+Version: 2.2.2p1
+Release: 1%{?dist}
Summary: Middleware for PHP
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
BuildRequires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-Requires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.3 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.3 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-diactoros": "^1.0",
+# "malukenho/docheader": "^0.1.5",
+# "phpunit/phpunit": "^5.7.22 || ^6.4.1"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.0 with php-autoloader(%{gh_owner}/laminas-diactoros) < 2)
# remirepo:6
%else
-BuildRequires: php-composer(psr/http-message) < 2
-BuildRequires: php-composer(psr/http-message) >= 1.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.3
+BuildRequires: php-laminas-escaper
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-psr-http-message
+BuildRequires: php-laminas-diactoros
%endif
-BuildRequires: php-composer(http-interop/http-middleware) >= 0.2
+BuildRequires: php-composer(http-interop/http-middleware) >= 0.5
+BuildRequires: php-composer(webimpress/http-middleware-compatibility) >= 0.1.4
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
-# From composer, "require-dev": {
-# "zendframework/zend-diactoros": "^1.0",
-# "phpunit/phpunit": "^5.6",
-# "zendframework/zend-coding-standard": "~1.0.0"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-diactoros) >= 1.0 with php-autoloader(%{gh_owner}/zend-diactoros) < 2)
-# remirepo:4
-%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-diactoros) < 2
-BuildRequires: php-autoloader(%{gh_owner}/zend-diactoros) >= 1.0
-%endif
-BuildRequires: php-composer(phpunit/phpunit) >= 5.6
+%if %{with_tests}
+BuildRequires: phpunit6 >= 6.4.1
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "psr/http-message": "^1.0",
-# "zendframework/zend-escaper": "^2.3",
-# "http-interop/http-middleware": "^0.2.0"
+# "php": "^5.6 || ^7.0",
+# "laminas/laminas-escaper": "^2.3",
+# "laminas/laminas-zendframework-bridge": "^1.0",
+# "psr/http-message": "^1.0",
+# "webimpress/http-middleware-compatibility": "^0.1.4"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-Requires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.3 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.3 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
# remirepo:6
%else
-Requires: php-composer(psr/http-message) >= 1.0
-Requires: php-composer(psr/http-message) < 2
-Requires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.3
-Requires: php-autoloader(%{gh_owner}/zend-escaper) < 3
-%endif
-Requires: php-composer(http-interop/http-middleware) >= 0.2
-# From composer, "suggest": {
-# "psr/http-message-implementation": "Please install a psr/http-message-implementation to consume Stratigility; e.g., zendframework/zend-diactoros"
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
-Suggests: php-autoloader(%{gh_owner}/zend-diactoros)
+Requires: php-laminas-escaper
+Requires: php-laminas-zendframework-bridge
+Requires: php-psr-http-message
%endif
+Requires: php-composer(http-interop/http-middleware) >= 0.5
+Requires: php-composer(webimpress/http-middleware-compatibility) >= 0.1.4
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.7.4
-Requires: php-pcre
+# From phpcompatinfo report for version 2.2.2
Requires: php-reflection
Requires: php-spl
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.2.2p1
+Provides: php-zendframework-%{zf_name} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
From "Strata", Latin for "layer", and "agility".
-This package supercedes and replaces phly/conduit.
-
Stratigility is a port of Sencha Connect to PHP.
It allows you to create and dispatch middleware pipelines.
-* File issues at https://github.com/zendframework/zend-stratigility/issues
-* Issue patches to https://github.com/zendframework/zend-stratigility/pulls
-* Documentation is at https://zendframework.github.io/zend-stratigility/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -118,46 +113,65 @@ It allows you to create and dispatch middleware pipelines.
mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/Interop/Http/Middleware/autoload.php';
-EOF
-
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Psr/Http/Message/autoload.php',
- '%{php_home}/Zend/Escaper/autoload.php',
- '%{php_home}/Interop/Http/Middleware/autoload.php',
+ '%{php_home}/%{namespace}/Escaper/autoload.php',
+ '%{php_home}/webimpress/http-middleware-compatibility/autoload.php',
+ __DIR__ . "/functions/double-pass-middleware.php",
+ __DIR__ . "/functions/middleware.php",
+ __DIR__ . "/functions/path.php",
+ __DIR__ . "/functions/double-pass-middleware.legacy.php",
+ __DIR__ . "/functions/middleware.legacy.php",
+ __DIR__ . "/functions/path.legacy.php",
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Diactoros/autoload.php',
+ '%{php_home}/%{namespace}/Diactoros/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
-%if %{with_tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\Route") ? 0 : 1);
+'
+
+%if %{with_tests}
+: upstream test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
- $cmd %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ $cmd %{_bindir}/phpunit6 || ret=1
fi
done
exit $ret
@@ -167,15 +181,22 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
-%{php_home}/Zend/%{library}-autoload.php
+%{php_home}/%{namespace}/%{library}
%changelog
+* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- switch to Laminas
+- update to 2.2.2p1
+- raise dependency on http-interop/http-middleware 0.5
+- add dependency on webimpress/http-middleware-compatibility
+
* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 1.3.3-7
- use range dependencies
- temporarily disable test suite