summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-21 09:14:08 +0100
committerRemi Collet <remi@php.net>2023-03-21 09:14:08 +0100
commit4088601850e952b5828da3b5e27abdc4b29b00c8 (patch)
tree2b05674700260c4b89578dc158e9d2320e9d40da
parent6a044136271dd5e08ae2f27c8e5e82fa1277061f (diff)
update to 3.17.0HEADmaster
raise dependency on PHP 8.1 switch to phpunit10
-rw-r--r--composer.json14
-rw-r--r--php-laminas-stdlib.spec39
2 files changed, 29 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 9c24411..6b487a4 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "8.0.99"
+ "php": "8.1.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -27,14 +27,14 @@
"extra": {
},
"require": {
- "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
+ "php": "~8.1.0 || ~8.2.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "^2.4.0",
- "phpbench/phpbench": "^1.2.7",
- "phpunit/phpunit": "^9.5.26",
- "psalm/plugin-phpunit": "^0.18.0",
- "vimeo/psalm": "^5.0.0"
+ "laminas/laminas-coding-standard": "^2.5",
+ "phpbench/phpbench": "^1.2.9",
+ "phpunit/phpunit": "^10.0.16",
+ "psalm/plugin-phpunit": "^0.18.4",
+ "vimeo/psalm": "^5.8"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-stdlib.spec b/php-laminas-stdlib.spec
index 0dc74bc..8efa898 100644
--- a/php-laminas-stdlib.spec
+++ b/php-laminas-stdlib.spec
@@ -1,7 +1,7 @@
# remirepo/Fedora spec file for php-laminas-stdlib
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -13,7 +13,7 @@
%bcond_without tests
%endif
-%global gh_commit f4f773641807c7ccee59b758bfe4ac4ba33ecb17
+%global gh_commit dd35c868075bad80b6718959740913e178eb4274
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-stdlib
@@ -23,11 +23,11 @@
%global library Stdlib
Name: php-%{gh_project}
-Version: 3.16.1
+Version: 3.17.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -50,20 +50,20 @@ BuildRequires: php-pcre
BuildRequires: php-posix
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.4.0",
-# "phpbench/phpbench": "^1.2.7",
-# "phpunit/phpunit": "^9.5.26",
-# "psalm/plugin-phpunit": "^0.18.0",
-# "vimeo/psalm": "^5.0.0"
-%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.26
+# "laminas/laminas-coding-standard": "^2.5",
+# "phpbench/phpbench": "^1.2.9",
+# "phpunit/phpunit": "^10.0.16",
+# "psalm/plugin-phpunit": "^0.18.4",
+# "vimeo/psalm": "^5.8"
+%global phpunit %{_bindir}/phpunit10
+BuildRequires: phpunit10 >= 10.0.16
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
-Requires: php(language) >= 8.0
+# "php": "~8.1.0 || ~8.2.0"
+Requires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# only require for compatibility layer
@@ -145,10 +145,10 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} $filter --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit10} || ret=1
fi
done
@@ -175,6 +175,11 @@ exit $ret
%changelog
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 3.17.0-1
+- update to 3.17.0
+- raise dependency on PHP 8.1
+- switch to phpunit10
+
* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 3.16.1-1
- update to 3.16.1