summaryrefslogtreecommitdiffstats
path: root/php-laminas-soap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-soap.spec')
-rw-r--r--php-laminas-soap.spec202
1 files changed, 202 insertions, 0 deletions
diff --git a/php-laminas-soap.spec b/php-laminas-soap.spec
new file mode 100644
index 0000000..c41ea20
--- /dev/null
+++ b/php-laminas-soap.spec
@@ -0,0 +1,202 @@
+# remirepo/Fedora spec file for php-zendframework-zend-soap
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 8762d79efa220d82529c43ce08d70554146be645
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-soap
+%global php_home %{_datadir}/php
+%global library Soap
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.8.0
+Release: 2%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-curl
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-soap
+BuildRequires: php-spl
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-server) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.21 || ^6.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-http": "^2.5.4"
+BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.6 with php-autoloader(%{gh_owner}/zend-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
+# remirepo:12
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-server) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-server) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
+%endif
+BuildRequires: phpunit6 >= 6.3
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "ext-soap": "*",
+# "zendframework/zend-server": "^2.6.1",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
+# "zendframework/zend-uri": "^2.5.2"
+Requires: php(language) >= 5.6
+Requires: php-soap
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-server) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-server) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
+Suggests: php-autoloader(%{gh_owner}/zend-http)
+# remirepo:8
+%else
+Requires: php-autoloader(%{gh_owner}/zend-server) < 3
+Requires: php-autoloader(%{gh_owner}/zend-server) >= 2.6.1
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-uri) < 3
+Requires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.1
+Requires: php-curl
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Soap is a component to manage the SOAP protocol in order
+to design client or server PHP application.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Server/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/Zend/Uri/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Http/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Config/autoload.php',
+ '%{php_home}/Zend/Http/autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+
+require_once 'test/TestAsset/commontypes.php';
+require_once 'test/TestAsset/call_user_func.php';
+EOF
+
+ret=0
+for cmd in php php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Thu May 2 2019 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- use range dependencies
+
+* Wed Jan 31 2018 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- Update to 2.7.0
+- raise dependency on PHP >= 5.6
+- switch to phpunit6
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.6.0-4
+- switch from zend-loader to fedora/autoloader
+
+* Fri Apr 22 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-server >= 2.6.1
+- raise dependency on zend-stdlib >= 2.7
+- raise dependency on zend-uri >= 2.5.2
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package