summaryrefslogtreecommitdiffstats
path: root/php-laminas-soap.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-14 17:24:49 +0200
committerRemi Collet <remi@php.net>2021-10-14 17:24:49 +0200
commitd7cfaf7e66975e739291f99f1f0bedbc5cd82b41 (patch)
treeefbb3ee895709c3ba330ec0c55812a150947d6e7 /php-laminas-soap.spec
parent8c3849503b4d0e12fa21da7c36283d5dc4f2cd21 (diff)
update to 2.10.0
raise dependency on PHP 7.4 keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on laminas-server 2.11 raise dependency on laminas-stdlib 3.6 raise dependency on laminas-uri 2.9.1
Diffstat (limited to 'php-laminas-soap.spec')
-rw-r--r--php-laminas-soap.spec50
1 files changed, 29 insertions, 21 deletions
diff --git a/php-laminas-soap.spec b/php-laminas-soap.spec
index 7a06f4d..6ce0bd1 100644
--- a/php-laminas-soap.spec
+++ b/php-laminas-soap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 11672a79e9074fd8e4e7aedd75849902e7b45e23
+%global gh_commit b1245a09b523485060407f73a0058fb871d2c656
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-soap
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -43,18 +43,18 @@ BuildRequires: php-soap
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.8 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^3.4",
-# "laminas/laminas-http": "^2.14",
+# "laminas/laminas-coding-standard": "~2.2.1",
+# "laminas/laminas-config": "^3.7",
+# "laminas/laminas-http": "^2.15",
# "phpspec/prophecy-phpunit": "^2.0.1",
-# "phpunit/phpunit": "^9.4.3"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+# "phpunit/phpunit": "^9.5.5"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.7 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:9
%else
@@ -67,28 +67,27 @@ BuildRequires: php-laminas-http
BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4.3
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "~7.4.0 || ~8.0.0 || ~8.1.0",
# "ext-dom": "*",
# "ext-soap": "*",
-# "laminas/laminas-server": "^2.9",
-# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-uri": "^2.8",
-# "laminas/laminas-zendframework-bridge": "^1.1.0"
+# "laminas/laminas-server": "^2.11",
+# "laminas/laminas-stdlib": "^3.6",
+# "laminas/laminas-uri": "^2.9.1",
Requires: php(language) >= 7.3
Requires: php-dom
Requires: php-soap
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.8 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "ext-curl": "Curl is required when .NET compatibility is required",
@@ -192,7 +191,7 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -215,6 +214,15 @@ exit $ret
%changelog
+* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on PHP 7.4
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on laminas-server 2.11
+- raise dependency on laminas-stdlib 3.6
+- raise dependency on laminas-uri 2.9.1
+
* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- raise dependency on PHP 7.3