summaryrefslogtreecommitdiffstats
path: root/php-laminas-soap.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-25 09:32:13 +0100
committerRemi Collet <remi@remirepo.net>2021-02-25 09:32:13 +0100
commitb9e3833df59f7d0ae6a00bd9b841067e7d016217 (patch)
treea16aa6d647ec31ba09b08714acbcd6329b3d401d /php-laminas-soap.spec
parentbf6cc37cdde1321caf78d815fb8c42186124d49b (diff)
update to 2.9.0
raise dependency on PHP 7.3 raise dependency on laminas-server 2.9 raise dependency on laminas-stdlib 3.2 raise dependency on laminas-uri 2.8 raise dependency on laminas-zendframework-bridge 1.1 switch to phpunit9
Diffstat (limited to 'php-laminas-soap.spec')
-rw-r--r--php-laminas-soap.spec86
1 files changed, 52 insertions, 34 deletions
diff --git a/php-laminas-soap.spec b/php-laminas-soap.spec
index 67c94cc..35e86a2 100644
--- a/php-laminas-soap.spec
+++ b/php-laminas-soap.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-soap
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 34f91d5c4c0a78bc5689cca2d1eaf829b27edd72
+%global gh_commit 11672a79e9074fd8e4e7aedd75849902e7b45e23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-soap
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-libxml
@@ -43,51 +43,58 @@ BuildRequires: php-soap
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.8 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^2.6",
-# "laminas/laminas-http": "^2.5.4",
-# "phpunit/phpunit": "^5.7.21 || ^6.3"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-# remirepo:8
+# "laminas/laminas-config": "^3.4",
+# "laminas/laminas-http": "^2.14",
+# "phpspec/prophecy-phpunit": "^2.0.1",
+# "phpunit/phpunit": "^9.4.3"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.14 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:9
%else
BuildRequires: php-laminas-server
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-uri
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config
+BuildRequires: php-laminas-config3
BuildRequires: php-laminas-http
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit6 >= 6.3
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
+# "ext-dom": "*",
# "ext-soap": "*",
-# "laminas/laminas-server": "^2.6.1",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
-# "laminas/laminas-uri": "^2.5.2",
-# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+# "laminas/laminas-server": "^2.9",
+# "laminas/laminas-stdlib": "^3.3",
+# "laminas/laminas-uri": "^2.8",
+# "laminas/laminas-zendframework-bridge": "^1.1.0"
+Requires: php(language) >= 7.3
+Requires: php-dom
Requires: php-soap
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-server) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.9 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.8 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
+# "ext-curl": "Curl is required when .NET compatibility is required",
# "laminas/laminas-http": "Laminas\\Http component"
Suggests: php-autoloader(%{gh_owner}/laminas-http)
-# remirepo:8
+# remirepo:6
%else
Requires: php-laminas-server
Requires: php-laminas-stdlib
@@ -99,16 +106,16 @@ Requires: php-laminas-zendframework-bridge
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.8.0
Requires: php-curl
-Requires: php-dom
Requires: php-libxml
Requires: php-pcre
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.8.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.8.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -168,8 +175,9 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config3/autoload.php',
'%{php_home}/%{namespace}/Http/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
dirname(__DIR__) . '/test/TestAsset/commontypes.php',
dirname(__DIR__) . '/test/TestAsset/call_user_func.php',
]);
@@ -184,9 +192,10 @@ exit (class_exists("\\Zend\\%{library}\\Server") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 || ret=1
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -206,6 +215,15 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-server 2.9
+- raise dependency on laminas-stdlib 3.2
+- raise dependency on laminas-uri 2.8
+- raise dependency on laminas-zendframework-bridge 1.1
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
- switch to Laminas