summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-02 10:03:16 +0100
committerRemi Collet <remi@remirepo.net>2020-11-02 10:03:16 +0100
commit21e5a1dc995e7d90040635b0606a741913b362db (patch)
tree33a4ce86f4a38ddec2a83085d5270b74cd5a3ee9
parent1321785ce4777b55a1112ecba089809402581bd6 (diff)
update to 2.10.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json16
-rw-r--r--php-laminas-session.spec42
2 files changed, 30 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index 42e08c6..fbf6271 100644
--- a/composer.json
+++ b/composer.json
@@ -19,18 +19,14 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.9.x-dev",
- "dev-develop": "2.10.x-dev"
- },
"laminas": {
"component": "Laminas\\Session",
"config-provider": "Laminas\\Session\\ConfigProvider"
}
},
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-eventmanager": "^3.0",
"laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
@@ -40,11 +36,12 @@
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-db": "^2.7",
"laminas/laminas-http": "^2.5.4",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-servicemanager": "^3.0.3",
"laminas/laminas-validator": "^2.6",
"mongodb/mongodb": "^1.0.1",
"php-mock/php-mock-phpunit": "^1.1.2 || ^2.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"laminas/laminas-cache": "Laminas\\Cache component",
@@ -60,9 +57,6 @@
}
},
"autoload-dev": {
- "files": [
- "test/autoload.php"
- ],
"psr-4": {
"LaminasTest\\Session\\": "test/"
}
diff --git a/php-laminas-session.spec b/php-laminas-session.spec
index 4b2568d..9e49496 100644
--- a/php-laminas-session.spec
+++ b/php-laminas-session.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 519e8966146536cd97c1cc3d59a21b095fb814d7
+%global gh_commit 921e6a9f807ee243a9a4f8a8a297929d0c2b50cd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-session
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.3
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-pcre
@@ -51,18 +51,21 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-db": "^2.7",
# "laminas/laminas-http": "^2.5.4",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-servicemanager": "^3.0.3",
# "laminas/laminas-validator": "^2.6",
# "mongodb/mongodb": "^1.0.1",
# "php-mock/php-mock-phpunit": "^1.1.2 || ^2.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.3"
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.7 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.5.4 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
-# remirepo:11
+BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.0 with php-composer(php-mock/php-mock-phpunit) < 3)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:13
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-stdlib
@@ -73,19 +76,20 @@ BuildRequires: php-laminas-db
BuildRequires: php-laminas-http
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-validator
+BuildRequires: php-mock-phpunit2 >= 2.1.0
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit7 >= 7.5.20
-BuildRequires: php-mock-phpunit2 >= 2.1.0
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-eventmanager": "^3.0",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -126,7 +130,7 @@ Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
Obsoletes: php-zendframework-%{zf_name} < 2.9.2
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -195,9 +199,9 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/phpmock2/phpunit/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
-require_once __DIR__ . '/../test/autoload.php';
EOF
: check compat autoloader
@@ -209,10 +213,9 @@ exit (class_exists("\\Zend\\%{library}\\Container") ? 0 : 1);
: upstream test suite
# Need investifation: testResumeSessionThatFailsAValidatorShouldRaiseException (ok for ZF)
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
- --filter '^((?!(testResumeSessionThatFailsAValidatorShouldRaiseException)).)*$' \
+ $cmd %{_bindir}/phpunit9 \
--verbose || ret=1
fi
done
@@ -233,6 +236,11 @@ exit $ret
%changelog
+* Mon Nov 2 2020 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.9.3-1
- update to 2.9.3 (no change)