summaryrefslogtreecommitdiffstats
path: root/php-laminas-server.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-server.spec')
-rw-r--r--php-laminas-server.spec118
1 files changed, 74 insertions, 44 deletions
diff --git a/php-laminas-server.spec b/php-laminas-server.spec
index 9f4fb3b..069bcd9 100644
--- a/php-laminas-server.spec
+++ b/php-laminas-server.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-server
+# remirepo/Fedora spec file for php-php-laminas-server
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d80c44700ebb92191dd9a3005316a6ab6637c0d1
+%global gh_commit 4aaca9174c40a2fab2e2aa77999da99f71bdd88e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-server
+%global gh_owner laminas
+%global gh_project laminas-server
+%global zf_name zend-server
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Server
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.8.1
-Release: 2%{?dist}
-Summary: Zend Framework %{library} component
+Release: 1%{?dist}
+Summary: Laminas Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -37,66 +39,68 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-code) >= 2.5 with php-autoloader(%{gh_owner}/zend-code) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.0 with php-autoloader(%{gh_owner}/laminas-code) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:8
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-code) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-code) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-code
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-code": "^2.5 || ^3.0"
-# "zendframework/zend-stdlib": "^2.5 || ^3.0",
+# "laminas/laminas-code": "^2.5 || ^3.0",
+# "laminas/laminas-stdlib": "^2.5 || ^3.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-code) >= 2.5 with php-autoloader(%{gh_owner}/zend-code) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:6
+Requires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.0 with php-autoloader(%{gh_owner}/laminas-code) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:5
%else
-Requires: php-autoloader(%{gh_owner}/zend-code) < 4
-Requires: php-autoloader(%{gh_owner}/zend-code) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
+Requires: php-laminas-code
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.6.0
+# From phpcompatinfo report for version 2.8.1
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.8.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-The Zend\Server family of classes provides functionality for the various
-server classes, including Zend\XmlRpc\Server and Zend\Json\Server.
-Zend\Server\Server provides an interface that mimics PHP 5’s SoapServer class;
-all server classes should implement this interface in order to provide a
+The %{gh_project} family of classes provides functionality for the various
+server classes, including %{namespace}\XmlRpc\Server and %{namespace}\Json\Server.
+%{namespace}\Server\Server provides an interface that mimics PHP 5’s SoapServer
+class; all server classes should implement this interface in order to provide a
standard server API.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -110,15 +114,29 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Code/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Code/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -126,11 +144,12 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
require_once 'test/TestAsset/reflectionTestFunction.php';
EOF
+: upstream test suite
ret=0
for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
@@ -138,6 +157,13 @@ for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -151,9 +177,13 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Wed Jan 8 2020 Remi Collet <remi@remirepo.net> - 2.8.1-1
+- switch to Laminas
+
* Thu Oct 17 2019 Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1
- drop patch merged upstream