summaryrefslogtreecommitdiffstats
path: root/php-laminas-server.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-server.spec')
-rw-r--r--php-laminas-server.spec25
1 files changed, 13 insertions, 12 deletions
diff --git a/php-laminas-server.spec b/php-laminas-server.spec
index 15a464f..9655117 100644
--- a/php-laminas-server.spec
+++ b/php-laminas-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c249f0638c8bdd67305509b7173bd535c21d109d
+%global gh_commit 572ce4194cb9024a06be2964d5be8c628a93ee66
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-server
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,15 +34,15 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 8.0
+BuildRequires: php(language) >= 7.4
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.1.4",
# "phpunit/phpunit": "^9.5.5",
-# "psalm/plugin-phpunit": "^0.15.1",
-#+ "vimeo/psalm": "^4.6.4"
+# "psalm/plugin-phpunit": "^0.18.0",
+#+ "vimeo/psalm": "^5.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.5.1 with php-autoloader(%{gh_owner}/laminas-code) < 5)
@@ -61,11 +61,10 @@ BuildRequires: phpunit9 >= 9.5.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-code": "^3.5.1 || ^4.0.0",
-# "laminas/laminas-stdlib": "^3.3.1",
-# "laminas/laminas-zendframework-bridge": "^1.2.0"
-Requires: php(language) >= 8.0
+# "laminas/laminas-stdlib": "^3.3.1"
+Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -154,7 +153,6 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
-require_once 'test/Reflection/TestAsset/functions.php';
require_once 'test/TestAsset/reflectionTestFunction.php';
EOF
@@ -170,7 +168,7 @@ done
: check compat autoloader
php -r '
require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
-exit (interface_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
+exit (interface_exists("\\Zend\\%{library}\\%{library}Interface") ? 0 : 1);
'
exit $ret
@@ -190,6 +188,9 @@ exit $ret
%changelog
+* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+
* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0 (no change)
- raise dependency on PHP 8.0