summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-24 06:49:04 +0100
committerRemi Collet <remi@remirepo.net>2020-11-24 06:49:04 +0100
commita3659e5c5702a7db2e525f06ba8fe34371825b26 (patch)
tree9b750c3f8e91e34a2123f314eb903e884bb70058
parentea078a404d9f69efb2d17cdcd543f980edd706c8 (diff)
update to 2.9.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json13
-rw-r--r--php-laminas-server.spec35
2 files changed, 27 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 485d675..c472c5c 100644
--- a/composer.json
+++ b/composer.json
@@ -19,20 +19,18 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.8.x-dev",
- "dev-develop": "2.9.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-code": "^2.5 || ^3.0",
"laminas/laminas-stdlib": "^2.5 || ^3.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "phpunit/phpunit": "^9.3",
+ "psalm/plugin-phpunit": "^0.13.0",
+ "vimeo/psalm": "^4.2"
},
"autoload": {
"psr-4": {
@@ -54,10 +52,11 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-server": "self.version"
+ "zendframework/zend-server": "^2.8.1"
}
}
diff --git a/php-laminas-server.spec b/php-laminas-server.spec
index 587d08f..aeba71d 100644
--- a/php-laminas-server.spec
+++ b/php-laminas-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4aaca9174c40a2fab2e2aa77999da99f71bdd88e
+%global gh_commit 9cce0abbdff0d873add767e36389b9df348bc0b5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-server
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.1
-Release: 2%{?dist}
+Version: 2.9.0
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -34,36 +34,38 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-reflection
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "phpunit/phpunit": "^9.3",
+# "psalm/plugin-phpunit": "^0.13.0",
+# "vimeo/psalm": "^4.2"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-code) >= 3.0 with php-autoloader(%{gh_owner}/laminas-code) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-# remirepo:8
+# remirepo:5
%else
BuildRequires: php-laminas-code
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-code": "^2.5 || ^3.0",
# "laminas/laminas-stdlib": "^2.5 || ^3.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -88,8 +90,8 @@ Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.8.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.8.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -154,10 +156,10 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
@@ -184,6 +186,11 @@ exit $ret
%changelog
+* Tue Nov 24 2020 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.8.1-2
- cleanup