summaryrefslogtreecommitdiffstats
path: root/php-laminas-serializer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-02-25 09:07:37 +0100
committerRemi Collet <remi@remirepo.net>2021-02-25 09:07:37 +0100
commitdeb2968f8fb16ee26edfd65d84f28858a00c91fe (patch)
tree696188e9a2c00519469db8d9c46a8adc39a5f3dc /php-laminas-serializer.spec
parent68b9992d537b3a945001abbd688e3da343479ec4 (diff)
update to 2.10.1
raise dependency on PHP 7.3 raise dependency on laminas-json 3.1 raise dependency on laminas-stdlib 3.2 switch to phpunit9
Diffstat (limited to 'php-laminas-serializer.spec')
-rw-r--r--php-laminas-serializer.spec71
1 files changed, 40 insertions, 31 deletions
diff --git a/php-laminas-serializer.spec b/php-laminas-serializer.spec
index 6c3135d..2f6a5d1 100644
--- a/php-laminas-serializer.spec
+++ b/php-laminas-serializer.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-php-laminas-serializer
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c1c9361f114271b0736db74e0083a919081af5e0
+%global gh_commit 254cf6a17b46d98808c0810939268f63538dcc0c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-serializer
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.1
-Release: 2%{?dist}
+Version: 2.10.1
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -42,44 +42,45 @@ BuildRequires: php-simplexml
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-math": "^2.6 || ^3.0",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
+# "laminas/laminas-math": "^3.3",
+# "laminas/laminas-servicemanager": "^3.6",
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-# remirepo:10
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.3 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# remirepo:7
%else
-BuildRequires: php-laminas-stdlib >= 3.0
-BuildRequires: php-laminas-json >= 3.0
+BuildRequires: php-laminas-stdlib >= 3.1
+BuildRequires: php-laminas-json >= 3.2
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-math >= 3.0
-BuildRequires: php-laminas-servicemanager >= 3.0.3
+BuildRequires: php-laminas-math >= 3.3
+BuildRequires: php-laminas-servicemanager >= 3.6
%endif
-BuildRequires: phpunit7 >= 7.5.16
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-json": "^2.5 || ^3.0",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-json": "^3.1",
+# "laminas/laminas-stdlib": "^3.2",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.1 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
-# "laminas/laminas-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
-# "laminas/laminas-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
+# "laminas/laminas-math": "(^3.3) To support Python Pickle serialization",
+# "laminas/laminas-servicemanager": "(^3.6) To support plugin manager support"
Suggests: php-autoloader(%{gh_owner}/laminas-math)
Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
Suggests: php-pecl(igbinary)
@@ -104,8 +105,8 @@ Requires: php-composer(fedora/autoloader)
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.9.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.9.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -169,9 +170,10 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit7 --verbose || ret=1
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
@@ -198,6 +200,13 @@ exit $ret
%changelog
+* Thu Feb 25 2021 Remi Collet <remi@remirepo.net> - 2.10.1-1
+- update to 2.10.1
+- raise dependency on PHP 7.3
+- raise dependency on laminas-json 3.1
+- raise dependency on laminas-stdlib 3.2
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.9.1-2
- cleanup