summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-07 15:16:05 +0100
committerRemi Collet <remi@remirepo.net>2020-01-07 15:16:05 +0100
commitc68b4d124edb1e55000a1773a5f2ab62ac7b8447 (patch)
treea87d9fbd6f71d5ce01d9fad8d0e08fab5ee7fe31
parent78c64b58cf388c7e9b6663a2f6ca2d8fa39d67e8 (diff)
switch to Laminas
-rw-r--r--composer.json68
-rw-r--r--php-laminas-serializer.spec137
2 files changed, 117 insertions, 88 deletions
diff --git a/composer.json b/composer.json
index 0312cc8..4554b55 100644
--- a/composer.json
+++ b/composer.json
@@ -1,56 +1,57 @@
{
- "name": "zendframework/zend-serializer",
+ "name": "laminas/laminas-serializer",
"description": "Serialize and deserialize PHP structures to a variety of representations",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"serializer"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-serializer/",
- "issues": "https://github.com/zendframework/zend-serializer/issues",
- "source": "https://github.com/zendframework/zend-serializer",
- "rss": "https://github.com/zendframework/zend-serializer/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-serializer/",
+ "issues": "https://github.com/laminas/laminas-serializer/issues",
+ "source": "https://github.com/laminas/laminas-serializer",
+ "rss": "https://github.com/laminas/laminas-serializer/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.9.x-dev",
+ "dev-develop": "2.10.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Serializer",
+ "config-provider": "Laminas\\Serializer\\ConfigProvider"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-json": "^2.5 || ^3.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "laminas/laminas-json": "^2.5 || ^3.0",
+ "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-math": "^2.6 || ^3.0",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-math": "^2.6 || ^3.0",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
},
"suggest": {
- "zendframework/zend-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
- "zendframework/zend-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
+ "laminas/laminas-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
+ "laminas/laminas-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
},
"autoload": {
"psr-4": {
- "Zend\\Serializer\\": "src/"
+ "Laminas\\Serializer\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Serializer\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.9.x-dev",
- "dev-develop": "2.10.x-dev"
- },
- "zf": {
- "component": "Zend\\Serializer",
- "config-provider": "Zend\\Serializer\\ConfigProvider"
+ "LaminasTest\\Serializer\\": "test/"
}
},
"scripts": {
@@ -62,5 +63,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-serializer": "self.version"
}
}
diff --git a/php-laminas-serializer.spec b/php-laminas-serializer.spec
index d42b9cd..9247820 100644
--- a/php-laminas-serializer.spec
+++ b/php-laminas-serializer.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-serializer
+# remirepo/Fedora spec file for php-php-laminas-serializer
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6fb7ae016cfdf0cfcdfa2b989e6a65f351170e21
+%global gh_commit c1c9361f114271b0736db74e0083a919081af5e0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-serializer
+%global gh_owner laminas
+%global gh_project laminas-serializer
+%global zf_name zend-serializer
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Serializer
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,20 +21,16 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.9.1
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: Laminas Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# remirepo:3
-# For test build on all available arch
-#global debug_package %%{nil}
-#global __debug_install_post /bin/true
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -43,26 +41,24 @@ BuildRequires: php-pcre
BuildRequires: php-simplexml
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-math": "^2.6 || ^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-math": "^2.6 || ^3.0",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.5 with php-autoloader(%{gh_owner}/zend-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 2.6 with php-autoloader(%{gh_owner}/zend-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:10
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-laminas-stdlib >= 3.0
+BuildRequires: php-laminas-json >= 3.0
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-math >= 3.0
+BuildRequires: php-laminas-servicemanager >= 3.0.3
%endif
BuildRequires: phpunit7 >= 7.5.16
%endif
@@ -71,30 +67,31 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-json": "^2.5 || ^3.0"
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-json": "^2.5 || ^3.0",
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.5 with php-autoloader(%{gh_owner}/zend-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:6
-%else
-Requires: php-autoloader(%{gh_owner}/zend-json) < 4
-Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-%endif
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
-# "zendframework/zend-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
-# "zendframework/zend-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
-Suggests: php-composer(%{gh_owner}/zend-math)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
+# "laminas/laminas-math": "(^2.6 || ^3.0) To support Python Pickle serialization",
+# "laminas/laminas-servicemanager": "(^2.7.5 || ^3.0.3) To support plugin manager support"
+Suggests: php-autoloader(%{gh_owner}/laminas-math)
+Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
Suggests: php-pecl(igbinary)
Suggests: php-pecl(msgpack)
+# remirepo:5
+%else
+Requires: php-laminas-json
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
+%endif
%endif
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.9.1
Requires: php-dom
Requires: php-libxml
Requires: php-pcre
@@ -103,18 +100,21 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.9.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-The Zend\Serializer component provides an adapter based interface
+The %{gh_project} component provides an adapter based interface
to simply generate storable representation of PHP types by different
facilities, and recover.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -127,19 +127,33 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Json/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Json/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Math/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Math/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -147,8 +161,8 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
@@ -157,6 +171,13 @@ for cmd in php php71 php72 php73 php74; do
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -170,9 +191,13 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Jan 7 2020 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- switch to Laminas
+
* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 2.9.1-1
- update to 2.9.1 (no change)
- switch to phpunit7