summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-26 07:57:24 +0100
committerRemi Collet <remi@remirepo.net>2021-01-26 07:57:24 +0100
commit184e3f083a825ca69f66f06440895a76a0ba1e10 (patch)
tree3561f2c796f820ebdee250c1728b0c15927ad072
parentfd07dbf2074be2aefdcbca8192a1b1aeaa3b9552 (diff)
update to 1.3.0 (no change)
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json8
-rw-r--r--php-laminas-psr7bridge.spec25
2 files changed, 17 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index ca0ff8f..62fb1cb 100644
--- a/composer.json
+++ b/composer.json
@@ -21,13 +21,9 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "1.2.x-dev",
- "dev-develop": "1.3.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-diactoros": "^1.7 || ^2.0",
"laminas/laminas-http": "^2.11",
"laminas/laminas-zendframework-bridge": "^1.0",
@@ -35,7 +31,7 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.15 || ^6.5.6 || ^7.5.20"
+ "phpunit/phpunit": "^9.4.1"
},
"conflict": {
"laminas/laminas-stdlib": "< 3.2.1"
diff --git a/php-laminas-psr7bridge.spec b/php-laminas-psr7bridge.spec
index be18107..0e7f045 100644
--- a/php-laminas-psr7bridge.spec
+++ b/php-laminas-psr7bridge.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-psr7bridge
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d310ce73aae9ff4723f7561539e33c79c38602fe
+%global gh_commit 6a46cf5b403be26ee87905247b87959e091c0058
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-psr7bridge
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.2.2
+Version: 1.3.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
BuildRequires: php-intl
BuildRequires: php-pcre
@@ -54,19 +54,19 @@ BuildRequires: php-psr-http-message
%endif
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.15 || ^6.5.6 || ^7.5.20"
-BuildRequires: phpunit7 >= 7.5.20
+# "phpunit/phpunit": "^9.4.1"
+BuildRequires: phpunit9 >= 9.4.1
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-diactoros": "^1.7 || ^2.0",
# "laminas/laminas-http": "^2.11",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/http-message": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
@@ -158,9 +158,9 @@ exit (class_exists("\\Zend\\%{library}\\Psr7Response") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 || ret=1
+ $cmd %{_bindir}/phpunit9 || ret=1
fi
done
exit $ret
@@ -180,6 +180,11 @@ exit $ret
%changelog
+* Tue Jan 26 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2 (no change)