summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-09 09:34:23 +0200
committerRemi Collet <remi@remirepo.net>2021-04-09 09:34:23 +0200
commitc72cff6439136d9538436f72ad76cf4a58caa65a (patch)
tree465246770a56c95a70f471ffb1447c771a25474f
parent2c1fa45bd1c1f269775526777db969acfff39f50 (diff)
update to 3.1.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json16
-rw-r--r--php-laminas-permissions-rbac.spec32
2 files changed, 28 insertions, 20 deletions
diff --git a/composer.json b/composer.json
index a249b8a..dc9a8c7 100644
--- a/composer.json
+++ b/composer.json
@@ -4,7 +4,7 @@
"license": "BSD-3-Clause",
"keywords": [
"laminas",
- "laminas-permssions-rbac",
+ "laminas-permissions-rbac",
"rbac",
"authorization"
],
@@ -21,18 +21,16 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "3.0.x-dev",
- "dev-develop": "3.1.x-dev"
- }
},
"require": {
- "php": "^7.1",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^7.0.1"
+ "phpunit/phpunit": "^9.3",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.7"
},
"autoload": {
"psr-4": {
@@ -47,14 +45,16 @@
"scripts": {
"check": [
"@cs-check",
+ "@static-analysis",
"@test"
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-permissions-rbac": "self.version"
+ "zendframework/zend-permissions-rbac": "^3.0.2"
}
}
diff --git a/php-laminas-permissions-rbac.spec b/php-laminas-permissions-rbac.spec
index a888757..2b4828a 100644
--- a/php-laminas-permissions-rbac.spec
+++ b/php-laminas-permissions-rbac.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-permissions-rbac
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 82757287735fc5c3d437aa59de65d61fe7d6b16c
+%global gh_commit ef224b6c7376d6fc8131b6d5b3609fe2583ffadb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-rbac
@@ -23,8 +23,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.0.2
-Release: 2%{?dist}
+Version: 3.1.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
License: BSD
@@ -35,28 +35,30 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^7.0.1"
+# "phpunit/phpunit": "^9.3",
+# "psalm/plugin-phpunit": "^0.15.1",
+# "vimeo/psalm": "^4.7"
# remirepo:3
%else
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.0.1
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.1",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -69,6 +71,7 @@ Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 3.0.2
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-Permissions-%{library} < 2.5
Provides: php-ZendFramework2-Permissions-%{library} = %{version}
# Compatibily ensure by the bridge
@@ -133,10 +136,10 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Role") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php72 php73 php74; do
+for cmd in "php %{phpunit}" php73 php74 php80; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--verbose || ret=1
fi
done
@@ -159,6 +162,11 @@ exit $ret
%changelog
+* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.0.2-2
- cleanup