summaryrefslogtreecommitdiffstats
path: root/php-laminas-permissions-acl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-permissions-acl.spec')
-rw-r--r--php-laminas-permissions-acl.spec153
1 files changed, 153 insertions, 0 deletions
diff --git a/php-laminas-permissions-acl.spec b/php-laminas-permissions-acl.spec
new file mode 100644
index 0000000..79366ea
--- /dev/null
+++ b/php-laminas-permissions-acl.spec
@@ -0,0 +1,153 @@
+# remirepo/Fedora spec file for zend-permissions-acl
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 1323e30a9357e6f6956f63d97faf7e8c8db1f4f8
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-permissions-acl
+%global php_home %{_datadir}/php
+%global library Acl
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.7.1
+Release: 2%{?dist}
+Summary: Zend Framework Permissions-%{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:6
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# From composer, "suggest": {
+# "zendframework/zend-servicemanager": "To support Zend\\Permissions\\Acl\\Assertion\\AssertionManager plugin manager usage"
+Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.1
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-Permissions-%{library} < 2.5
+Provides: php-ZendFramework2-Permissions-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Provides a lightweight and flexible access control list (ACL)
+implementation for privileges management.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/Permissions/
+cp -pr src %{buildroot}%{php_home}/Zend/Permissions/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/Permissions/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Permissions\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/Zend
+%dir %{php_home}/Zend/Permissions
+ %{php_home}/Zend/Permissions/%{library}
+
+
+%changelog
+* Tue Jun 25 2019 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 2.7.0-2
+- update to 2.7.0
+- raise dependency on PHP 5.6
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.6.0-4
+- switch from zend-loader to fedora/autoloader
+
+* Thu Feb 4 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package