summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-laminas-permissions-acl.spec15
2 files changed, 14 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index e5ffbd2..b376aef 100644
--- a/composer.json
+++ b/composer.json
@@ -28,7 +28,9 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-servicemanager": "^3.0.3",
- "phpunit/phpunit": "^9.5"
+ "phpunit/phpunit": "^9.5.0",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.7"
},
"suggest": {
"laminas/laminas-servicemanager": "To support Laminas\\Permissions\\Acl\\Assertion\\AssertionManager plugin manager usage"
@@ -50,6 +52,7 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
diff --git a/php-laminas-permissions-acl.spec b/php-laminas-permissions-acl.spec
index fe5ff93..1b87c16 100644
--- a/php-laminas-permissions-acl.spec
+++ b/php-laminas-permissions-acl.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7af6463695d76dbf25c6b03e6ebb792c8f1ab67e
+%global gh_commit 13f30605fe83e2e917168b8510ca59916c307a8c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-acl
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.0
+Version: 2.8.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -43,7 +43,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-servicemanager": "^3.0.3",
-# "phpunit/phpunit": "^9.5"
+# "phpunit/phpunit": "^9.5.0",
+# "psalm/plugin-phpunit": "^0.15.1",
+# "vimeo/psalm": "^4.7"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:4
%else
@@ -51,7 +53,7 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-servicemanager
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -148,7 +150,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Acl") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -173,6 +175,9 @@ exit $ret
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.8.1-1
+- update to 2.8.1
+
* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
- update to 2.8.0
- raise dependency on PHP 7.3