summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-03 12:32:40 +0100
committerRemi Collet <remi@php.net>2021-12-03 12:32:40 +0100
commitea0ef451af5b7dd03468da008e9339272c35dd81 (patch)
tree422d80334f054d3c681789e095c0fb4f5135075a
parent228558e48c694cff0919b3be583897f776ffb79b (diff)
update to 2.9.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json9
-rw-r--r--php-laminas-permissions-acl.spec12
2 files changed, 11 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index b376aef..f4f6dec 100644
--- a/composer.json
+++ b/composer.json
@@ -19,11 +19,11 @@
"sort-packages": true
},
"conflict": {
- "laminas/laminas-servicemanager": "<3.0"
+ "laminas/laminas-servicemanager": "<3.0",
+ "zendframework/zend-permissions-acl": "*"
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -55,8 +55,5 @@
"static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
- },
- "replace": {
- "zendframework/zend-permissions-acl": "^2.7.1"
}
}
diff --git a/php-laminas-permissions-acl.spec b/php-laminas-permissions-acl.spec
index 1b87c16..4a3fcd9 100644
--- a/php-laminas-permissions-acl.spec
+++ b/php-laminas-permissions-acl.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 13f30605fe83e2e917168b8510ca59916c307a8c
+%global gh_commit cd5689d8360c9a3f29bb62b32fc8ad45e0947e1e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-acl
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.1
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -59,8 +59,7 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0"
Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
@@ -175,6 +174,11 @@ exit $ret
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1