summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-09 09:26:40 +0200
committerRemi Collet <remi@remirepo.net>2021-04-09 09:26:40 +0200
commit29b278aca90383c5bd98c7056b87301faef82dc3 (patch)
tree10df448f73ec95cdaedf1ca9cfcf2f14770e3c9b
parent13ef11ef472bd60689ce63f0ee9d3aabb58dc85e (diff)
update to 2.8.0
raise dependency on PHP 7.3 raise dependency on laminas-servicemanager 3.0.3 switch to phpunit9
-rw-r--r--composer.json9
-rw-r--r--php-laminas-permissions-acl.spec38
2 files changed, 23 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index b195f9a..e5ffbd2 100644
--- a/composer.json
+++ b/composer.json
@@ -18,16 +18,17 @@
"config": {
"sort-packages": true
},
- "extra": {
+ "conflict": {
+ "laminas/laminas-servicemanager": "<3.0"
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
+ "laminas/laminas-servicemanager": "^3.0.3",
+ "phpunit/phpunit": "^9.5"
},
"suggest": {
"laminas/laminas-servicemanager": "To support Laminas\\Permissions\\Acl\\Assertion\\AssertionManager plugin manager usage"
diff --git a/php-laminas-permissions-acl.spec b/php-laminas-permissions-acl.spec
index 29fc87f..fe5ff93 100644
--- a/php-laminas-permissions-acl.spec
+++ b/php-laminas-permissions-acl.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d8cd35ed94eef5d3d2533af4a72cf1c2932084bb
+%global gh_commit 7af6463695d76dbf25c6b03e6ebb792c8f1ab67e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-permissions-acl
@@ -23,8 +23,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.2
-Release: 3%{?dist}
+Version: 2.8.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
License: BSD
@@ -35,31 +35,31 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# "laminas/laminas-servicemanager": "^3.0.3",
+# "phpunit/phpunit": "^9.5"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:4
%else
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-servicemanager
%endif
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -146,20 +146,12 @@ require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php";
exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Acl") ? 0 : 1);
'
-: for phpunit8/9
-find test -name \*.php \
- -exec sed \
- -e 's/function setUp()/function setUp():void/' \
- -e 's/function tearDown()/function tearDown():void/' \
- -i {} \;
-
-
: upstream test suite
ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -181,6 +173,12 @@ exit $ret
%changelog
+* Fri Apr 9 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-servicemanager 3.0.3
+- switch to phpunit9
+
* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 2.7.2-3
- switch to phpunit8