summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-22 11:25:49 +0200
committerRemi Collet <remi@php.net>2022-07-22 11:25:49 +0200
commita7d8e98d59926a55de2b72834cdd76263e3f076e (patch)
tree0cbce9c18c30806e8392136d537787817a04f6b7
parent24daaa20dbb8d4d7a28f6fd0a51b5663676b9e87 (diff)
update to 2.14.0 (no change)
-rw-r--r--composer.json15
-rw-r--r--php-laminas-navigation.spec13
2 files changed, 21 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index aebc3ad..ec40307 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"laminas": {
@@ -40,7 +46,9 @@
"laminas/laminas-uri": "^2.9.1",
"laminas/laminas-view": "^2.14.2",
"phpspec/prophecy-phpunit": "^2.0.1",
- "phpunit/phpunit": "^9.5.10"
+ "phpunit/phpunit": "^9.5.10",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24"
},
"suggest": {
"laminas/laminas-config": "^3.7, to provide page configuration (optional, as arrays and Traversables are also allowed)",
@@ -67,7 +75,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"conflict": {
"zendframework/zend-navigation": "*"
diff --git a/php-laminas-navigation.spec b/php-laminas-navigation.spec
index 63e5ac3..449f030 100644
--- a/php-laminas-navigation.spec
+++ b/php-laminas-navigation.spec
@@ -8,7 +8,7 @@
#
# when build without permission-acl
%global bootstrap 0
-%global gh_commit ca7c4df621bba21494b62722c46cd9326ca3e360
+%global gh_commit dfdb42d4eb4a9290950fbb674bb20718b4b9a4b4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-navigation
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.13.2
+Version: 2.14.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -46,7 +46,9 @@ BuildRequires: php-spl
# "laminas/laminas-uri": "^2.9.1",
# "laminas/laminas-view": "^2.14.2",
# "phpspec/prophecy-phpunit": "^2.0.1",
-# "phpunit/phpunit": "^9.5.10"
+# "phpunit/phpunit": "^9.5.10",
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -204,7 +206,7 @@ exit (class_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
# testProvidesExpectedConfiguration need fix after Laminas move
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -231,6 +233,9 @@ exit $ret
%changelog
+* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
+- update to 2.14.0 (no change)
+
* Thu Feb 17 2022 Remi Collet <remi@remirepo.net> - 2.13.2-1
- update to 2.13.2 (no change)