summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 13:51:21 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 13:51:21 +0100
commit746dfc9d0ba9dcb21fa7cab2c5514e47b543337e (patch)
tree754f32d8e60f42e8f8856eff1be85993eb3f6672
parent44362ac549209f02b0f9581e95fe3e6c362eafc8 (diff)
switch to Laminas
-rw-r--r--composer.json90
-rw-r--r--php-laminas-navigation.spec228
2 files changed, 174 insertions, 144 deletions
diff --git a/composer.json b/composer.json
index 1df5536..16e84a1 100644
--- a/composer.json
+++ b/composer.json
@@ -1,67 +1,68 @@
{
- "name": "zendframework/zend-navigation",
+ "name": "laminas/laminas-navigation",
"description": "Manage trees of pointers to web pages in order to build navigation systems",
"license": "BSD-3-Clause",
"keywords": [
- "zendframework",
- "zf",
+ "laminas",
"navigation"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-navigation/",
- "issues": "https://github.com/zendframework/zend-navigation/issues",
- "source": "https://github.com/zendframework/zend-navigation",
- "rss": "https://github.com/zendframework/zend-navigation/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-navigation/",
+ "issues": "https://github.com/laminas/laminas-navigation/issues",
+ "source": "https://github.com/laminas/laminas-navigation",
+ "rss": "https://github.com/laminas/laminas-navigation/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.9.x-dev",
+ "dev-develop": "2.10.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Navigation",
+ "config-provider": "Laminas\\Navigation\\ConfigProvider"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-config": "^2.6 || ^3.1",
- "zendframework/zend-console": "^2.6",
- "zendframework/zend-http": "^2.6",
- "zendframework/zend-i18n": "^2.7.3",
- "zendframework/zend-log": "^2.9.1",
- "zendframework/zend-mvc": "^2.7.9 || ^3.0.4",
- "zendframework/zend-permissions-acl": "^2.6",
- "zendframework/zend-router": "^3.0.2",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-uri": "^2.5.2",
- "zendframework/zend-view": "^2.9"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-config": "^2.6 || ^3.1",
+ "laminas/laminas-console": "^2.6",
+ "laminas/laminas-http": "^2.6",
+ "laminas/laminas-i18n": "^2.7.3",
+ "laminas/laminas-log": "^2.9.1",
+ "laminas/laminas-mvc": "^2.7.9 || ^3.0.4",
+ "laminas/laminas-permissions-acl": "^2.6",
+ "laminas/laminas-router": "^3.0.2",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-uri": "^2.5.2",
+ "laminas/laminas-view": "^2.9",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
},
"suggest": {
- "zendframework/zend-config": "^2.6 || ^3.1, to provide page configuration (optional, as arrays and Traversables are also allowed)",
- "zendframework/zend-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
- "zendframework/zend-router": "^3.0, to use router-based URI generation with Mvc pages",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
- "zendframework/zend-view": "^2.8.1, to use the navigation view helpers"
+ "laminas/laminas-config": "^2.6 || ^3.1, to provide page configuration (optional, as arrays and Traversables are also allowed)",
+ "laminas/laminas-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
+ "laminas/laminas-router": "^3.0, to use router-based URI generation with Mvc pages",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
+ "laminas/laminas-view": "^2.8.1, to use the navigation view helpers"
},
"autoload": {
"psr-4": {
- "Zend\\Navigation\\": "src/"
+ "Laminas\\Navigation\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Navigation\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.9.x-dev",
- "dev-develop": "2.10.x-dev"
- },
- "zf": {
- "component": "Zend\\Navigation",
- "config-provider": "Zend\\Navigation\\ConfigProvider"
+ "LaminasTest\\Navigation\\": "test/"
}
},
"scripts": {
@@ -73,5 +74,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-navigation": "self.version"
}
}
diff --git a/php-laminas-navigation.spec b/php-laminas-navigation.spec
index 65a3efe..83028a9 100644
--- a/php-laminas-navigation.spec
+++ b/php-laminas-navigation.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-navigation
+# remirepo/Fedora spec file for php-laminas-navigation
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit fd3c60b83e816cfb67b53c2193372ac19469a609
+%global gh_commit 1b4210ea3afeffb8a69e502e169088180ba3275d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-navigation
+%global gh_owner laminas
+%global gh_project laminas-navigation
+%global zf_name zend-navigation
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Navigation
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.9.1
-Release: 2%{?dist}
-Summary: Zend Framework %{library} component
+Release: 1%{?dist}
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -36,112 +38,107 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^2.6 || ^3.1",
-# "zendframework/zend-console": "^2.6",
-# "zendframework/zend-http": "^2.6",
-# "zendframework/zend-i18n": "^2.7.3",
-# "zendframework/zend-log": "^2.9.1",
-# "zendframework/zend-mvc": "^2.7.9 || ^3.0.4",
-# "zendframework/zend-permissions-acl": "^2.6",
-# "zendframework/zend-router": "^3.0.2",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-uri": "^2.5.2",
-# "zendframework/zend-view": "^2.9"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^2.6 || ^3.1",
+# "laminas/laminas-console": "^2.6",
+# "laminas/laminas-http": "^2.6",
+# "laminas/laminas-i18n": "^2.7.3",
+# "laminas/laminas-log": "^2.9.1",
+# "laminas/laminas-mvc": "^2.7.9 || ^3.0.4",
+# "laminas/laminas-permissions-acl": "^2.6",
+# "laminas/laminas-router": "^3.0.2",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-uri": "^2.5.2",
+# "laminas/laminas-view": "^2.9",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.6 with php-autoloader(%{gh_owner}/zend-config) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-console) >= 2.6 with php-autoloader(%{gh_owner}/zend-console) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.6 with php-autoloader(%{gh_owner}/zend-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7.3 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-log) >= 2.9.1 with php-autoloader(%{gh_owner}/zend-log) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 2.7.9 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-permissions-acl) >= 2.6 with php-autoloader(%{gh_owner}/zend-permissions-acl) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0.2 with php-autoloader(%{gh_owner}/zend-router) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-view) >= 2.9 with php-autoloader(%{gh_owner}/zend-view) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
-# remirepo:28
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.6 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7.3 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-log) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-log) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0.4 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-permissions-acl) >= 2.6 with php-autoloader(%{gh_owner}/laminas-permissions-acl) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.2 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.9 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+# remirepo:15
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-console) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-console) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7.3
-BuildRequires: php-autoloader(%{gh_owner}/zend-log) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-log) >= 2.9.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 2.7.9
-BuildRequires: php-autoloader(%{gh_owner}/zend-permissions-acl) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-permissions-acl) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) >= 3.0.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-uri) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-view) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-view) >= 2.9
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-config
+BuildRequires: php-laminas-console
+BuildRequires: php-laminas-http
+BuildRequires: php-laminas-i18n
+BuildRequires: php-laminas-log
+BuildRequires: php-laminas-mvc
+BuildRequires: php-laminas-permissions-acl
+BuildRequires: php-laminas-router
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-uri
+BuildRequires: php-laminas-view
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-config": "^2.6 || ^3.1, to provide page configuration (optional, as arrays and Traversables are also allowed)",
+# "laminas/laminas-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
+# "laminas/laminas-router": "^3.0, to use router-based URI generation with Mvc pages",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
+# "laminas/laminas-view": "^2.8.1, to use the navigation view helpers"
+Suggests: php-autoloader(%{gh_owner}/laminas-config)
+Suggests: php-autoloader(%{gh_owner}/laminas-permissions-acl)
+Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
+Suggests: php-autoloader(%{gh_owner}/laminas-router)
+Suggests: php-autoloader(%{gh_owner}/laminas-view)
# remirepo:4
%else
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
-# From composer, "suggest": {
-# "zendframework/zend-config": "^2.6 || ^3.1, to provide page configuration (optional, as arrays and Traversables are also allowed)",
-# "zendframework/zend-permissions-acl": "^2.6, to provide ACL-based access restrictions to pages",
-# "zendframework/zend-router": "^3.0, to use router-based URI generation with Mvc pages",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, to use the navigation factories",
-# "zendframework/zend-view": "^2.8.1, to use the navigation view helpers"
-Suggests: php-autoloader(%{gh_owner}/zend-config)
-Suggests: php-autoloader(%{gh_owner}/zend-permissions-acl)
-Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
-Suggests: php-autoloader(%{gh_owner}/zend-router)
-Suggests: php-autoloader(%{gh_owner}/zend-view)
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.6.0
+# From phpcompatinfo report for version 2.9.1
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.9.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Navigation is a component for managing trees of pointers to web pages.
+%{namespace}\Navigation is a component for managing trees of pointers to web pages.
Simply put: It can be used for creating menus, breadcrumbs, links,
and sitemaps, or serve as a model for other navigation related purposes.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -155,21 +152,35 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Config/autoload.php',
- '%{php_home}/Zend/Permissions/Acl/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Router/autoload.php',
- '%{php_home}/Zend/View/autoload.php',
+ '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Permissions/Acl/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Router/autoload.php',
+ '%{php_home}/%{namespace}/View/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -177,23 +188,33 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Console/autoload.php',
- '%{php_home}/Zend/Http/autoload.php',
- '%{php_home}/Zend/I18n/autoload.php',
- '%{php_home}/Zend/Log/autoload.php',
- '%{php_home}/Zend/Mvc/autoload.php',
- '%{php_home}/Zend/Uri/autoload.php',
+ '%{php_home}/%{namespace}/Console/autoload.php',
+ '%{php_home}/%{namespace}/Http/autoload.php',
+ '%{php_home}/%{namespace}/I18n/autoload.php',
+ '%{php_home}/%{namespace}/Log/autoload.php',
+ '%{php_home}/%{namespace}/Mvc/autoload.php',
+ '%{php_home}/%{namespace}/Uri/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{library}") ? 0 : 1);
+'
+
+# testProvidesExpectedConfiguration need fix after Laminas move
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} \
+ --filter '^((?!(testProvidesExpectedConfiguration)).)*$' \
+ --verbose || ret=1
fi
done
exit $ret
@@ -203,14 +224,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 2.9.1-1
+- switch to Laminas
+
* Wed Aug 21 2019 Remi Collet <remi@remirepo.net> - 2.9.1-2
- update to 2.9.1