summaryrefslogtreecommitdiffstats
path: root/php-laminas-mvc.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-20 10:18:41 +0200
committerRemi Collet <remi@php.net>2022-10-20 10:18:41 +0200
commit8f8ac47d6c5793a2141f05e7bdcc7155d9a8afc4 (patch)
tree3a3cc53c70535fcc06a61cf1859fe4db1dea94ad /php-laminas-mvc.spec
parent6c0772affee3596fb92a5d357855c827ab01f9dd (diff)
update to 3.4.0
raise dependency on PHP 8.0
Diffstat (limited to 'php-laminas-mvc.spec')
-rw-r--r--php-laminas-mvc.spec36
1 files changed, 22 insertions, 14 deletions
diff --git a/php-laminas-mvc.spec b/php-laminas-mvc.spec
index 1ed445a..961b76d 100644
--- a/php-laminas-mvc.spec
+++ b/php-laminas-mvc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 43fa8b0a02376cfe3209a91140bc97e94cd62d6e
+%global gh_commit 4ccca214621659fe75b748b377d5ba6a313a878b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.3.5
+Version: 3.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 8.0
BuildRequires: php-reflection
BuildRequires: php-json
BuildRequires: php-pcre
@@ -51,18 +51,20 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.14
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# from composer.json, "require-dev": {
# "http-interop/http-middleware": "^0.4.1",
-# "laminas/laminas-coding-standard": "^1.0.0",
+# "laminas/laminas-coding-standard": "^2.4.0",
# "laminas/laminas-json": "^3.3",
-# "laminas/laminas-psr7bridge": "^1.0",
+# "laminas/laminas-psr7bridge": "^1.8",
# "laminas/laminas-stratigility": ">=2.0.1 <2.2",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5.5"
+# "phpspec/prophecy" : "^1.15.0",
+# "phpspec/prophecy-phpunit": "^2.0.1",
+# "phpunit/phpunit": "^9.5.25"
BuildRequires: (php-composer(http-interop/http-middleware) >= 0.4.1 with php-composer(http-interop/http-middleware) < 1)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-psr7bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-psr7bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-psr7bridge) >= 1.8 with php-autoloader(%{gh_owner}/laminas-psr7bridge) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stratigility) >= 2.0.1 with php-autoloader(%{gh_owner}/laminas-stratigility) < 3)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:15
+BuildRequires: (php-composer(phpspec/prophecy) >= 1.15 with php-composer(phpspec/prophecy) < 2)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:16
%else
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-http
@@ -76,16 +78,17 @@ BuildRequires: php-http-interop-http-middleware
BuildRequires: php-laminas-json
BuildRequires: php-laminas-psr7bridge
BuildRequires: php-laminas-stratigility
+BuildRequires: php-phpspec-prophecy
BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "container-interop/container-interop": "^1.2",
# "laminas/laminas-eventmanager": "^3.4",
# "laminas/laminas-http": "^2.15",
@@ -94,7 +97,7 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-servicemanager": "^3.7",
# "laminas/laminas-stdlib": "^3.6",
# "laminas/laminas-view": "^2.14"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
@@ -242,6 +245,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Prophecy/autoload.php',
'%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
require_once 'test/_autoload.php';
@@ -258,7 +262,7 @@ rm test/MiddlewareListenerTest.php
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -281,6 +285,10 @@ exit $ret
%changelog
+* Thu Oct 20 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- raise dependency on PHP 8.0
+
* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 3.3.5-1
- update to 3.3.5