summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-14 08:54:20 +0200
committerRemi Collet <remi@php.net>2021-10-14 08:54:20 +0200
commite0594a104d69b9689af55f31c26196b52d9ed7d3 (patch)
tree8540b5fe4036f12c574b7f83a481e19c01e2d1c9
parent6c55e6cfe7ee9b4bb784b5ab0f353e7396bbc11a (diff)
update to 3.3.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on laminas-eventmanager 3.4 raise dependency on laminas-http 2.15 raise dependency on laminas-router 3.5 raise dependency on laminas-servicemanager 3.7 raise dependency on laminas-stdlib 3.6 raise dependency on laminas-view 2.14
-rw-r--r--composer.json23
-rw-r--r--php-laminas-mvc.spec66
2 files changed, 49 insertions, 40 deletions
diff --git a/composer.json b/composer.json
index 483148d..ed563ed 100644
--- a/composer.json
+++ b/composer.json
@@ -21,25 +21,24 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"container-interop/container-interop": "^1.2",
- "laminas/laminas-eventmanager": "^3.2",
- "laminas/laminas-http": "^2.7",
+ "laminas/laminas-eventmanager": "^3.4",
+ "laminas/laminas-http": "^2.15",
"laminas/laminas-modulemanager": "^2.8",
- "laminas/laminas-router": "^3.0.2",
- "laminas/laminas-servicemanager": "^3.3",
- "laminas/laminas-stdlib": "^3.2.1",
- "laminas/laminas-view": "^2.11.3",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-router": "^3.5",
+ "laminas/laminas-servicemanager": "^3.7",
+ "laminas/laminas-stdlib": "^3.6",
+ "laminas/laminas-view": "^2.14"
},
"require-dev": {
"http-interop/http-middleware": "^0.4.1",
"laminas/laminas-coding-standard": "^1.0.0",
- "laminas/laminas-json": "^2.6.1 || ^3.0",
+ "laminas/laminas-json": "^3.3",
"laminas/laminas-psr7bridge": "^1.0",
"laminas/laminas-stratigility": ">=2.0.1 <2.2",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.4.2"
+ "phpunit/phpunit": "^9.5.5"
},
"suggest": {
"laminas/laminas-json": "(^2.6.1 || ^3.0) To auto-deserialize JSON body content in AbstractRestfulController extensions, when json_decode is unavailable",
@@ -77,7 +76,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-mvc": "^3.1.1"
+ "conflict": {
+ "zendframework/zend-mvc": "*"
}
}
diff --git a/php-laminas-mvc.spec b/php-laminas-mvc.spec
index 049a360..c5f136a 100644
--- a/php-laminas-mvc.spec
+++ b/php-laminas-mvc.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-mvc
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 88da7200cf8f5a970c35d91717a5c4db94981e5e
+%global gh_commit 215d0ff1b504bfbc299346aae20acb362c38d139
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
+Version: 3.3.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -42,24 +42,24 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.8 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.2 with php-autoloader(%{gh_owner}/laminas-router) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.11.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.5 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.14 with php-autoloader(%{gh_owner}/laminas-view) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# from composer.json, "require-dev": {
# "http-interop/http-middleware": "^0.4.1",
# "laminas/laminas-coding-standard": "^1.0.0",
-# "laminas/laminas-json": "^2.6.1 || ^3.0",
+# "laminas/laminas-json": "^3.3",
# "laminas/laminas-psr7bridge": "^1.0",
# "laminas/laminas-stratigility": ">=2.0.1 <2.2",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.4.2"
+# "phpunit/phpunit": "^9.5.5"
BuildRequires: (php-composer(http-interop/http-middleware) >= 0.4.1 with php-composer(http-interop/http-middleware) < 1)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.3 with php-autoloader(%{gh_owner}/laminas-json) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-psr7bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-psr7bridge) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stratigility) >= 2.0.1 with php-autoloader(%{gh_owner}/laminas-stratigility) < 3)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
@@ -81,33 +81,32 @@ BuildRequires: php-laminas-stratigility
BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4.2
+BuildRequires: phpunit9 >= 9.5.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.",
# "container-interop/container-interop": "^1.2",
-# "laminas/laminas-eventmanager": "^3.2",
-# "laminas/laminas-http": "^2.7",
+# "laminas/laminas-eventmanager": "^3.4",
+# "laminas/laminas-http": "^2.15",
# "laminas/laminas-modulemanager": "^2.8",
-# "laminas/laminas-router": "^3.0.2",
-# "laminas/laminas-servicemanager": "^3.3",
-# "laminas/laminas-stdlib": "^3.2.1",
-# "laminas/laminas-view": "^2.11.3",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-router": "^3.4",
+# "laminas/laminas-servicemanager": "^3.7",
+# "laminas/laminas-stdlib": "^3.6",
+# "laminas/laminas-view": "^2.14"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.8 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0.2 with php-autoloader(%{gh_owner}/laminas-router) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.11.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.5 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.14 with php-autoloader(%{gh_owner}/laminas-view) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-json": "(^2.6.1 || ^3.0) To auto-deserialize JSON body content in AbstractRestfulController extensions, when json_decode is unavailable",
@@ -264,7 +263,7 @@ rm test/MiddlewareListenerTest.php
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -287,6 +286,17 @@ exit $ret
%changelog
+* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on laminas-eventmanager 3.4
+- raise dependency on laminas-http 2.15
+- raise dependency on laminas-router 3.5
+- raise dependency on laminas-servicemanager 3.7
+- raise dependency on laminas-stdlib 3.6
+- raise dependency on laminas-view 2.14
+
* Tue Dec 15 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0
- raise dependency on PHP 7.3