summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 15:55:28 +0100
committerRemi Collet <remi@php.net>2021-12-07 15:55:28 +0100
commitfad5f677ed9b6c23b8d13af86c86089e906cd205 (patch)
tree03f81ee9106bb2df39737ac894c014329ab8ec62
parent57f961b77f7d72d61b5d982a0f22dd6af74ebfae (diff)
update to 1.4.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json7
-rw-r--r--php-laminas-mvc-plugin-prg.spec14
2 files changed, 12 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index dd74e95..40633c2 100644
--- a/composer.json
+++ b/composer.json
@@ -27,8 +27,7 @@
"php": "^7.3 || ~8.0.0",
"laminas/laminas-mvc": "^3.0",
"laminas/laminas-session": "^2.8.5",
- "laminas/laminas-stdlib": "^3.3.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^3.3.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -54,7 +53,7 @@
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-mvc-plugin-prg": "^1.2.0"
+ "conflict": {
+ "zendframework/zend-mvc-plugin-prg": "*"
}
}
diff --git a/php-laminas-mvc-plugin-prg.spec b/php-laminas-mvc-plugin-prg.spec
index 29a8a2d..f06ed01 100644
--- a/php-laminas-mvc-plugin-prg.spec
+++ b/php-laminas-mvc-plugin-prg.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 943c03a869a1a421ce3c6dc2f034021b247d9b17
+%global gh_commit 054b0a4c69d095de64869652ac24be89213f8d8f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-prg
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.0
+Version: 1.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -63,8 +63,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-mvc": "^3.0",
# "laminas/laminas-session": "^2.8.5",
-# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^3.3"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -154,7 +153,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -179,6 +178,11 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0
- raise dependency on PHP 7.3