summaryrefslogtreecommitdiffstats
path: root/php-laminas-mvc-plugin-flashmessenger.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-mvc-plugin-flashmessenger.spec')
-rw-r--r--php-laminas-mvc-plugin-flashmessenger.spec61
1 files changed, 37 insertions, 24 deletions
diff --git a/php-laminas-mvc-plugin-flashmessenger.spec b/php-laminas-mvc-plugin-flashmessenger.spec
index 12d9a06..6bf40e2 100644
--- a/php-laminas-mvc-plugin-flashmessenger.spec
+++ b/php-laminas-mvc-plugin-flashmessenger.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-mvc-plugin-flashmessenger
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 178339e7eb0e34e220e2fe543832f4eed7fb5705
+%global gh_commit 86bb1c654e5fafaf34d4deaa7dc9af721fbcb42d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-flashmessenger
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.5.0
+Version: 1.8.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -36,20 +36,22 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.12.0 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.4 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.13.1 with php-autoloader(%{gh_owner}/laminas-view) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-i18n": "^2.8",
-# "phpunit/phpunit": "^9.3"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.8 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-i18n": "^2.13.0",
+# "phpunit/phpunit": "^9.5.4",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.18"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.13.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# remirepo:8
%else
BuildRequires: php-laminas-mvc
@@ -60,24 +62,24 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-i18n
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
-# "laminas/laminas-mvc": "^3.0",
-# "laminas/laminas-session": "^2.8.5",
-# "laminas/laminas-stdlib": "^3.2.1",
-# "laminas/laminas-view": "^2.12"
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "laminas/laminas-mvc": "^3.3",
+# "laminas/laminas-session": "^2.12.0",
+# "laminas/laminas-stdlib": "^3.6.4",
+# "laminas/laminas-view": "^2.13.1"
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.12.0 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.4 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.13.1 with php-autoloader(%{gh_owner}/laminas-view) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggests": {
# "laminas/laminas-i18n": "Laminas\\I18n component"
@@ -174,7 +176,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -199,6 +201,17 @@ exit $ret
%changelog
+* Tue Jun 28 2022 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+
+* Mon Jan 10 2022 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+- raise dependency on PHP 7.4
+- raise dependency on laminas-mvc 3.3
+- raise dependency on laminas-session 2.12.0
+- raise dependency on laminas-stdlib 3.6.4
+- raise dependency on laminas-view 2.13.1
+
* Wed Dec 8 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
- update to 1.5.0 (no change)
- keep compatibility using laminas-zendframework-bridge