summaryrefslogtreecommitdiffstats
path: root/php-laminas-mvc-plugin-flashmessenger.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-mvc-plugin-flashmessenger.spec')
-rw-r--r--php-laminas-mvc-plugin-flashmessenger.spec188
1 files changed, 188 insertions, 0 deletions
diff --git a/php-laminas-mvc-plugin-flashmessenger.spec b/php-laminas-mvc-plugin-flashmessenger.spec
new file mode 100644
index 0000000..69ae432
--- /dev/null
+++ b/php-laminas-mvc-plugin-flashmessenger.spec
@@ -0,0 +1,188 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-plugin-flashmessenger
+#
+# Copyright (c) 2016-2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit b66064eb59d3b124a133d259aac3d9dd7cb81706
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-plugin-flashmessenger
+%global php_home %{_datadir}/php
+%global library FlashMessenger
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2.0
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-Plugin-%{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-i18n": "^2.8"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-view) >= 2.10 with php-autoloader(%{gh_owner}/zend-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.8 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:14
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-view) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-view) >= 2.10
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.8
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-mvc": "^3.0",
+# "zendframework/zend-session": "^2.8.5",
+# "zendframework/zend-stdlib": "^3.2.1",
+# "zendframework/zend-view": "^2.10"
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8.5 with php-autoloader(%{gh_owner}/zend-session) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-view) >= 2.10 with php-autoloader(%{gh_owner}/zend-view) < 3)
+# remirepo:10
+%else
+Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
+Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-session) < 3
+Requires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-autoloader(%{gh_owner}/zend-view) < 3
+Requires: php-autoloader(%{gh_owner}/zend-view) >= 2.10
+%endif
+# From composer, "suggests": {
+# "zendframework/zend-i18n": "Zend\\I18n component"
+Suggests: php-autoloader(%{gh_owner}/zend-i18n)
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 1.0.0
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Flash messages derive from Rails, and are used to expose messages from one
+action to the next, after which they are cleared; a typical use case is with
+Post/Redirect/Get, where they are created in the POST handler, and then
+displayed by the GET handler to indicate success or failure to the end-user.
+
+This component provides a flash messenger controller plugin for zend-mvc
+versions 3.0 and up.
+
+* Issues at https://github.com/zendframework/zend-mvc-plugin-flashmessenger/issues
+* Documentation is at https://zendframework.github.io/zend-mvc-plugin-flashmessenger/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Mvc/autoload.php',
+ '%{php_home}/Zend/Session/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/Mvc/Plugin
+cp -pr src %{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/Mvc/Plugin/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\Plugin\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/Mvc/Plugin/%{library}
+
+
+%changelog
+* Mon Oct 21 2019 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- raise dependency on zend-stdlib 3.2.1
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- raise dependency on zend-session 2.8.5
+- add dependency on zend-view
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
+* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 1.0.0-4
+- switch from zend-loader to fedora/autoloader
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package
+